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Introduction 
Blackboard Learn Release 9.1 is the first release to offer an entire application and database 
footprint using 64-bit addressable memory. To take advantage of more addressable memory, 
Blackboard strongly encourages clients to deploy using 64-bit operating systems (OSs) and sub 
components (Java and SQL Server or Oracle). Migrating to 64-bit operating systems allows 
institutions to deploy a 64-bit JVM with larger heap sizes that suppresses the need to run in 
Tomcat clustered environments.  

Blackboard Learn 9.1 Service Pack 8 (SP8) requires a 64-bit operating system. Clients 
upgrading to SP8 must upgrade their operating system before upgrading the application. 
Instructions in this guide will help you through the process of migrating from a 32-bit system to a 
64-bit system. 
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Migration Guide 
Nomenclature 
The source application server ($SRC_APP_HOSTNAME) refers to the original server running 
your production Blackboard application instance, running on a Microsoft Windows Server 32-bit 
operating system. 

The source database server ($SRC_DB_HOSTNAME) refers to the original server running 
your production Blackboard database instance, running on a Microsoft Windows Server 32-bit 
operating system. 

The destination application server ($DST_APP_HOSTNAME) refers to the new server which 
is intended as the application instance migration target of this process, running on a Microsoft 
Windows Server 64-bit operating system. 

The destination database server ($DST_DB_HOSTNAME) refers to the new server which is 
intended as the database instance migration target of this process, running on a Microsoft 
Windows Server 64-bit operating system. 

Process Overview and Server Combination Scenarios 
When performing Blackboard Learn migrations from 32-bit platforms to 64-bit platforms, there 
are five distinct actions that take place in order, regardless of your server combinations: 

• Backup the Application 
• Backup the Database 
• Restore the Database 
• Restore the Application 
• Upgrade the Application 

In order to condense this guide, each of these sections is written exactly once in such a manner 
that it can apply to any server combination that may be installed. As long as these actions are 
followed in order and unique hostnames are correctly specified during the restore steps, the 
migration process will be successful. 
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One Server to One Server 
The source application server and source database server are the same 
(%SRC_APP_HOSTNAME% == %SRC_DB_HOSTNAME%).  

The destination application server and the destination database server are the same 
(%DST_APP_HOSTNAME% == %DST_DB_HOSTNAME%).  

Blackboard content is backed up and restored with the application. 
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One Server to Two Servers 
The source application server and source database server are the same 
(%SRC_APP_HOSTNAME% == %SRC_DB_HOSTNAME%).  

The destination application server and the destination database server are separate 
(%DST_APP_HOSTNAME% != %DST_DB_HOSTNAME%).  

Blackboard content is backed up and restored with the database. 
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Two Servers to Two Servers 
The source application server and source database server are separate 
(%SRC_APP_HOSTNAME% != %SRC_DB_HOSTNAME%). 

The destination application server and the destination database server are separate 
(%DST_APP_HOSTNAME% != %DST_DB_HOSTNAME%). 

Blackboard content is backed up and restored with the database. This is also a general case for 
many-server installations that are load-balanced. 
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Source Server Assumptions 
If your configuration varies from these assumptions, then these instructions must be adjusted to 
fit your environment. 

Source Application Server (%SRC_APP_HOSTNAME%) 
You are running one of the following versions of Microsoft Windows Server:  

• Microsoft Windows Server 2003 Enterprise Edition 32-bit 

You are running one of the following versions of Blackboard Learn:  

• Blackboard Learn 8.0 SP7 (8.0.494.0) 
• Blackboard Learn 8.0 SP7 HF1 (8.0.494.5) 
• Blackboard Learn 8.0 SP7 HF2 (8.0.494.35) 
• Blackboard Learn 9.0 SP7 (9.0.692.0) 

You are planning to upgrade to Blackboard Learn 9.1 SP8 (9.1.82223.0). 

You have a full Blackboard License which includes the Learning System, the Content System, 
the Community System and the Outcomes System.  

• This guide will work with other license types, but the database and database user counts 
may be different than what is reflected in this guide. 

You have installed Blackboard to c:\blackboard. 

You are running the latest version of JDK 1.6 32-bit at c:\jdk1.6.0_30 (update 30 was used 
for this writing). 

You are running the Blackboard appserver on port 8009 and the webserver on port 80. 

Your collab server is running on port 8010 and port 8011. 

You know your SMTP server hostname. 

For one-server configurations:  

• Your shared content location is c:\blackboard\content. 
• Your storage location for /courses is c:\blackboard\content\storage\courses. 
• Your storage location for /institution is 

c:\blackboard\content\storage\institution. 
• Your storage location for /library is c:\blackboard\content\storage\library. 
• Your storage location for /orgs is c:\blackboard\content\storage\orgs. 
• Your storage location for /users is c:\blackboard\content\storage\users. 

For two-server configurations:  

• Your shared content location is \\%SRC_DB_HOSTNAME%\bb_content. 
• Your storage location for /courses is 

\\%SRC_DB_HOSTNAME%\bb_content\storage\courses. 
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• Your storage location for /institution is 
\\%SRC_DB_HOSTNAME%\bb_content\storage\institution. 

• Your storage location for /library is 
\\%SRC_DB_HOSTNAME%\bb_content\storage\library. 

• Your storage location for /orgs is 
\\%SRC_DB_HOSTNAME%\bb_content\storage\orgs. 

• Your storage location for /users is 
\\%SRC_DB_HOSTNAME%\bb_content\storage\users. 

Source Database Server (%SRC_DB_HOSTNAME%) 
You are running one of the following versions of Microsoft Windows Server: 

• Microsoft Windows Server 2003 Enterprise Edition 32-bit 

You are running one of the following versions of SQL Server and you know the instance name 
(ENG1 in this document). 

• SQL Server 2005 SP3 (9.0.4053.0) 32-bit 

You know your database "sa" administrator password. 

Your database data files directory is c:\blackboard\mssql\data. 

Your database log files directory is c:\blackboard\mssql\data. 

For two-server configurations, your shared content location is c:\bb_content which is shared 
via CIFS as \\%SRC_DB_HOSTNAME%\bb_content. 
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Destination Server Assumptions  
Destination Application Server (%DST_APP_HOSTNAME%) 
You are running one of the following versions of Microsoft Windows Server:  

• Windows Server 2008 R2 Enterprise Edition 64-bit 

You have the latest version of JDK 1.6 64-bit installed at c:\jdk1.6.0_30 (update 30 was used 
for this writing). 

Destination Database Server (%DST_DB_HOSTNAME%) 
You are running one of the following versions of Microsoft Windows Server:  

• Windows Server 2008 R2 Enterprise Edition 64-bit 

You are running one of the following versions of Microsoft SQL Server on port 1433/tcp and you 
know the instance name (ENG1 in this document).  

• Microsoft SQL Server 2008 SP1 (10.0.2531.0) 

Your database data files directory is c:\blackboard\mssql\data. 

Your database log files directory is c:\blackboard\mssql\data. 

For two-server configurations, your shared content location is c:\bb_content which is shared 
via CIFS as \\%DST_DB_HOSTNAME%\bb_content. 
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Prepare Destination Server 
This work should be done as the Active Directory domain user that runs your Blackboard Learn 
instance (e.g. %DOMAIN%\blackboard), which has been granted administrative access to your 
servers. 

The domain user (e.g. %DOMAIN%\blackboard) must be granted the "Log On as a Service" and 
"Log On as a Batch Job" rights on the server or within the domain so that services can be 
started on the application server. 

Warning: When doing work through the command line, be sure to run the Command Prompt as 
administrator (right-click, Run as administrator) or you may see permissions errors. 

Destination Application Server ($DST_APP_HOSTNAME) 
1. Increase the maximum number of ephemeral ports from 5000 to 65534, per Microsoft 

KB196271. Requires a reboot.  
 

Windows Registry Editor Version 5.00 

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters] 

"MaxUserPort"=dword:0000fffe 

 

2. Disable User Account Control.  
A. Start > Control Panel > User Accounts 
B. Change User Account Control settings 
C. Never notify > Ok 

3. Install the IIS 7 Role and configure Role Services.  
A. Right-click Computer > Manage 
B. Server Manager > Roles > Roles Summary > Add Roles 
C. Server Roles > Web Server (IIS) > Next > Next 
D. The following seven (7) role services are REQUIRED:  

i. Web Server > Application Development > ISAPI Extensions 
ii. Web Server > Application Development > ISAPI Filters 
iii. Web Server > Performance > Static Content Compression 
iv. Web Server > Performance > Dynamic Content Compression 
v. Management Tools > IIS 6 Management Compatibility > IIS 6 Metabase 

Compatibility 
vi. Management Tools > IIS 6 Management Compatibility > IIS 6 WMI 

Compatibility 
vii. Management Tools > IIS 6 Management Compatibility > IIS 6 Scripting 

Tools 
E. The following four (4) role services are RECOMMENDED, to enhance 

management and troubleshooting capabilities:  
i. Web Server > Common HTTP Features > HTTP Errors 
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ii. Web Server > Health and Diagnostics > HTTP Logging 
iii. Management Tools > IIS Management Console 
iv. Management Tools > IIS Management Scripts and Tools 

F. The following role service is OPTIONAL. It should only be used if your installation 
has a legacy integration with Active Directory using web server authentication. 
The preferred method for integration with Active Directory is to use the LDAP 
authentication provider.  

i. Security > Windows Authentication 
 

4. Remove the Default Web Site.  
A. Right-click Computer > Manage 
B. Server Manager > Roles > Web Server (IIS) > Internet Information Services (IIS) 

Manager 
C. Connections > %HOSTNAME% > Sites > right-click Default Web Site > Remove 

 
5. Configure IIS 7 to allow double escaping within URLS and the upload of files greater 

than 20MB in size (applies to all sites).  

 

%windir%\system32\inetsrv\appcmd.exe add backup "Blackboard Pre-
Change Backup" 

 

%windir%\system32\inetsrv\appcmd.exe list backup 

 

%windir%\system32\inetsrv\appcmd set config ^ 

/section:system.webServer/Security/requestFiltering ^ 

-allowDoubleEscaping:True 

%windir%\system32\inetsrv\appcmd set config ^ 

-section:requestFiltering ^ 

-requestLimits.maxAllowedContentLength:104857600 

 

%windir%\system32\inetsrv\appcmd.exe add backup "Blackboard Post-
Change Backup" 

 

%windir%\system32\inetsrv\appcmd.exe list backup 

 

6. Restart the IIS service.  
A. Right-click Computer > Manage 
B. Server Manager > Configuration > Services 
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C. Right-click World Wide Web Publishing Service > Restart 
 

7. Configure IIS 7 security.  
A. Right-click Computer > Manage 
B. Server Manager > Roles > Web Server (IIS) > Internet Information Services (IIS) 

Manager 
C. Configure Directory Security.  

i. %HOSTNAME% > Authentication 
ii. right-click Anonymous Authentication > Enabled 
iii. right-click Anonymous Authentication > Edit 
iv. Specific User: IUSR (this is the default value) 

D. Configure the Application Pool.  
i. %HOSTNAME% > Application Pools > right-click DefaultAppPool > 

Advanced Settings 
ii. Process Model > Identity > ... > Custom Account > Set... > enter the 

domain user name, e.g. %DOMAIN%\blackboard 
iii. Ok > Ok > Ok 

E. Restart IIS so that the changes will take effect. 
 

8. Add the Domain User to the IIS_IUSRS Group.  
A. Right-click Computer > Manage 
B. Server Manager > Configuration > Local Users and Groups > Groups 
C. Right-click IIS_IUSRS > Add to group... > Add... 
D. Enter the domain user "%DOMAIN%\blackboard". 
E. Ok > Ok 

 
9. Set the JAVA_HOME variable.  

A. Right-click Computer > Properties 
B. Advanced System Settings > Tab: Advanced > Environment Variables... 
C. System Variables list:  

i. If the JAVA_HOME variable exists, verify that it matches the installation 
path for the JDK. 

ii. If the JAVA_HOME variable does not exist in the System Variables list, 
then click New.  

a. Variable Name: JAVA_HOME 
b. Variable Value: enter the full path to the JDK, such as 

c:\jdk1.6.0_30 
D. Ok > Ok > Ok 
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10. Create a directory for Blackboard Learn backup files. Create a CIFS share for the 

directory.  

mkdir c:\public 

net share public=c:\public /grant:%DOMAIN%\blackboard,FULL 

Destination Database Server (%DST_DB_HOSTNAME%) 
1. Configure SQL Server Agent for automatic startup.  

A. Right-click Computer > Manage 
B. Server Manager > Configuration > Services 
C. Right-click SQL Server Agent (%INSTANCE%) > Properties 
D. Startup Type: Automatic 
E. Ok 

 
2. Configure SQL Server to listen on port 1433/tcp.  

A. Start > Programs > Microsoft SQL Server > Configuration Tools > SQL Server 
Configuration Manager 

B. SQL Server Configuration Manager (Local) > SQL Server Network Configuration 
> Protocols for %INSTANCE% 

C. Right-click TCP/IP > Properties 
D. Tab: IP Addresses > IPAll 
E. TCP Dynamic Ports: blank 
F. TCP Port: 1433 
G. Ok 
H. Restart the SQL Server service. 

 
3. Create a directory for the Blackboard Learn database backup files. Create a CIFS share 

for the directory.  

mkdir c:\public 

net share public=c:\public /grant:%DOMAIN%\blackboard,FULL 
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Backup the Application on the Source Server 
Source Application Server (%SRC_APP_HOSTNAME%) 

1. Shutdown the Blackboard Learn instance. 
 
c:\blackboard\tools\admin\ServiceController.bat services.stop 

 
2. Export the SSL Certificate as a PFX file.  

a. Right-click My Computer > Manage 
b. Services and Applications > Internet Information Services (IIS) Manager 
c. Web Sites > right-click blackboard_bb_bb60 > Properties 
d. Tab: Directory Security > Server Certificate > Next 
e. Export the current certificate to a .pfx file > Next 
f. Path and file name: c:\ssl_backup\ssl_cert.pfx > Next 
g. Password: %PASSWORD% > Confirm Password: %PASSWORD% > Next > 

Next > Finish 
 

3. Map a network drive to the destination application server. 
 
net use z: \\%DST_APP_SERVER%\public 

 
4. Copy the Blackboard Learn application (and content) to the destination application 

server. For Windows Server 2003, the robocopy utility is part of the Windows Server 
2003 Resource Kit Tools. 

a. One-server source, one-server destination; exclude the database files. 
 
robocopy /E c:\blackboard z:\blackboard /XD c:\blackboard\mssql 
robocopy /E c:\ssl_backup z:\ssl_backup 
net use z: /delete 
 

b. One-server source, two-server destination; exclude the database and content 
files. 

 
robocopy /E c:\blackboard z:\blackboard /XD c:\blackboard\mssql /XD 
c:\blackboard\content 
robocopy /E c:\ssl_backup z:\ssl_backup 
net use z: /delete 
 

c. Two-server source, two-server destination. 
 
robocopy /E c:\blackboard z:\blackboard 
robocopy /E c:\ssl_backup z:\ssl_backup 
net use z: /delete 
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Backup the Database on the Source Server 
If you have a full Blackboard license which includes the Learning System, the Content System, 
the Community System and the Outcomes System, then there are 10 schemas and 5 users to 
backup. If you do not have all of these modules licensed, then there will be fewer schemas and 
users to backup and you should adjust these scripts as necessary. 

Source Database Server (%SRC_DB_HOSTNAME%) 
1. Create a directory to store the database backup.  

 
mkdir c:\sql_backup 

 
2. Start SQL Server Management Studio, log in as the "sa" administrator users and 

connect to the Blackboard instance (e.g. ENG1). 
 

3. Backup the SQL Server 2005 database schemas for the Blackboard application. There 
are 10 schemas to backup.  

A. New Query > Execute 
 

BACKUP LOG bbadmin WITH TRUNCATE_ONLY 

BACKUP LOG bb_bb60 WITH TRUNCATE_ONLY 

BACKUP LOG bb_bb60_stats WITH TRUNCATE_ONLY 

BACKUP LOG cms WITH TRUNCATE_ONLY 

BACKUP LOG cms_doc WITH TRUNCATE_ONLY 

BACKUP LOG cms_files_courses WITH TRUNCATE_ONLY 

BACKUP LOG cms_files_inst WITH TRUNCATE_ONLY 

BACKUP LOG cms_files_library WITH TRUNCATE_ONLY 

BACKUP LOG cms_files_orgs WITH TRUNCATE_ONLY 

BACKUP LOG cms_files_users WITH TRUNCATE_ONLY 

BACKUP DATABASE bb_bb60 TO DISK = 'C:\sql_backup\bb_bb60.bak' 

BACKUP DATABASE bb_bb60_stats TO DISK = 
'C:\sql_backup\bb_bb60_stats.bak' 

BACKUP DATABASE bbadmin TO DISK = 'C:\sql_backup\bbadmin.bak' 

BACKUP DATABASE cms TO DISK = 'C:\sql_backup\cms.bak' 

BACKUP DATABASE cms_doc TO DISK = 'C:\sql_backup\cms_doc.bak' 

BACKUP DATABASE cms_files_courses TO DISK = 
'C:\sql_backup\cms_files_courses.bak' 

BACKUP DATABASE cms_files_inst TO DISK = 
'C:\sql_backup\cms_files_inst.bak' 
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BACKUP DATABASE cms_files_library TO DISK = 
'C:\sql_backup\cms_files_library.bak' 

BACKUP DATABASE cms_files_orgs TO DISK = 
'C:\sql_backup\cms_files_orgs.bak' 

BACKUP DATABASE cms_files_users TO DISK = 
'C:\sql_backup\cms_files_users.bak' 

 

4. Backup the SQL Server 2005 users for the Blackboard application. 
 

5. We will be creating and executing a new version of the sp_help_revlogin stored 
procedure based on the listing in Microsoft KB246133 to accomplish this task. This script 
was originally written for SQL Server 2000 and it has issues running in SQL Server 
2005, so we will use an updated version posted on Laurentiu Cristofor's Apr 3, 2006 blog 
at Microsoft. This script will generate SQL code that will be used to recreate the logins 
on the destination server; save this output to a text file. 

A. New Query > Execute  

USE master 

GO 

IF OBJECT_ID ('sp_hexadecimal') IS NOT NULL 

 DROP PROCEDURE sp_hexadecimal 

GO 

 

CREATE PROCEDURE sp_hexadecimal 

  @binvalue varbinary(256), 

  @hexvalue varchar (514) OUTPUT 

AS 

DECLARE @charvalue varchar (514) 

DECLARE @i int 

DECLARE @length int 

DECLARE @hexstring char(16) 

SELECT @charvalue = '0x' 

SELECT @i = 1 

SELECT @length = DATALENGTH (@binvalue) 

SELECT @hexstring = '0123456789ABCDEF' 

WHILE (@i <= @length) 

BEGIN 
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  DECLARE @tempint int 

  DECLARE @firstint int 

  DECLARE @secondint int 

  SELECT @tempint = CONVERT(int, SUBSTRING(@binvalue,@i,1)) 

  SELECT @firstint = FLOOR(@tempint/16) 

  SELECT @secondint = @tempint - (@firstint*16) 

  SELECT @charvalue = @charvalue + 

    SUBSTRING(@hexstring, @firstint+1, 1) + 

    SUBSTRING(@hexstring, @secondint+1, 1) 

  SELECT @i = @i + 1 

END 

SELECT @hexvalue = @charvalue 

GO 

 

IF OBJECT_ID ('sp_help_revlogin') IS NOT NULL 

  DROP PROCEDURE sp_help_revlogin 

GO 

CREATE PROCEDURE sp_help_revlogin @login_name sysname = NULL AS 

DECLARE @name sysname 

DECLARE @type varchar (1) 

DECLARE @hasaccess int 

DECLARE @denylogin int 

DECLARE @is_disabled int 

DECLARE @PWD_varbinary  varbinary (256) 

DECLARE @PWD_string  varchar (514) 

DECLARE @SID_varbinary varbinary (85) 

DECLARE @SID_string varchar (514) 

DECLARE @tmpstr  varchar (1024) 

DECLARE @is_policy_checked varchar (3) 

DECLARE @is_expiration_checked varchar (3) 

 

IF (@login_name IS NULL) 

  DECLARE login_curs CURSOR FOR 
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SELECT p.sid, p.name, p.type, p.is_disabled, l.hasaccess, 
l.denylogin 

      FROM sys.server_principals p LEFT JOIN sys.syslogins l ON ( 
l.name = p.name ) 

WHERE p.type IN ( 'S', 'G', 'U' ) AND p.name <> 'sa' 

ELSE 

  DECLARE login_curs CURSOR FOR 

    SELECT p.sid, p.name, p.type, p.is_disabled, l.hasaccess, 
l.denylogin 

FROM sys.server_principals p LEFT JOIN sys.syslogins l ON ( 
l.name = p.name ) 

WHERE p.type IN ( 'S', 'G', 'U' ) AND p.name = @login_name 

OPEN login_curs 

FETCH NEXT FROM login_curs INTO @SID_varbinary, @name, @type, 
@is_disabled, @hasaccess, @denylogin 

IF (@@fetch_status = -1) 

BEGIN 

  PRINT 'No login(s) found.' 

  CLOSE login_curs 

  DEALLOCATE login_curs 

  RETURN -1 

END 

SET @tmpstr = '/* sp_help_revlogin script ' 

PRINT @tmpstr 

SET @tmpstr = '** Generated ' + CONVERT (varchar, GETDATE()) + ' 
on ' + @@SERVERNAME + ' */' 

PRINT @tmpstr 

PRINT '' 

WHILE (@@fetch_status <> -1) 

BEGIN 

  IF (@@fetch_status <> -2) 

  BEGIN 

    PRINT '' 

    SET @tmpstr = '-- Login: ' + @name 

    PRINT @tmpstr 
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    IF (@type IN ( 'G', 'U')) 

    BEGIN -- NT authenticated account/group 

SET @tmpstr = 'CREATE LOGIN ' + QUOTENAME( @name ) + ' FROM 
WINDOWS' 

END 

ELSE BEGIN -- SQL Server authentication 

  -- obtain password and sid 

  SET @PWD_varbinary = CAST( LOGINPROPERTY( @name, 'PasswordHash' 
) AS varbinary (256) ) 

  EXEC sp_hexadecimal @PWD_varbinary, @PWD_string OUT 

  EXEC sp_hexadecimal @SID_varbinary, @SID_string OUT 

  -- obtain password policy state 

  SELECT @is_policy_checked = 

    CASE is_policy_checked WHEN 1 THEN 'ON' WHEN 0 THEN 'OFF' 
ELSE NULL END 

    FROM sys.sql_logins WHERE name = @name 

  SELECT @is_expiration_checked = 

    CASE is_expiration_checked WHEN 1 THEN 'ON' WHEN 0 THEN 'OFF' 
ELSE NULL END 

    FROM sys.sql_logins WHERE name = @name 

  SET @tmpstr = 'CREATE LOGIN ' + QUOTENAME( @name ) 

    + ' WITH PASSWORD = ' + @PWD_string 

    + ' HASHED, SID = ' + @SID_string 

  IF ( @is_policy_checked IS NOT NULL ) 

  BEGIN 

SET @tmpstr = @tmpstr + ', CHECK_POLICY = ' + 
@is_policy_checked 

  END 

  IF ( @is_expiration_checked IS NOT NULL ) 

  BEGIN 

    SET @tmpstr = @tmpstr + ', CHECK_EXPIRATION = ' + 
@is_expiration_checked 

  END 

END 
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IF (@denylogin = 1) 

BEGIN -- login is denied access 

  SET @tmpstr = @tmpstr + '; DENY CONNECT SQL TO ' + QUOTENAME( 
@name ) 

END 

ELSE IF (@hasaccess = 0) 

BEGIN -- login has exists but does not have access 

  SET @tmpstr = @tmpstr + '; REVOKE CONNECT SQL TO ' + QUOTENAME( 
@name ) 

END 

 

IF (@is_disabled = 1) 

BEGIN -- login is disabled 

SET @tmpstr = @tmpstr + '; ALTER LOGIN ' + QUOTENAME( @name ) + 
' DISABLE' 

END 

PRINT @tmpstr 

END 

FETCH NEXT FROM login_curs INTO @SID_varbinary, @name, @type, 
@is_disabled, @hasaccess, @denylogin 

END 

CLOSE login_curs 

DEALLOCATE login_curs 

RETURN 0 

GO 

 

B. New Query > Execute 
 

EXEC master..sp_help_revlogin 

 

This is sample output from the sp_help_revlogin stored procedure, restricted 
to the five Blackboard Learn database logins. Save the output related to the five 
Blackboard Learn database logins to a new text file 
c:\sql_backup\create_login.txt. If you have additional logins in your 
database related to Blackboard Learn, then be sure to include them as well. 
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-- Login: bbadmin 

CREATE LOGIN [bbadmin] WITH PASSWORD = 
0x01009B0B2830D545616B065BBCAEAE2F4AA80C7A906245034D2D HASHED, 
SID = 0x5769680D7874044A8FA68762FF01E9FB, CHECK_POLICY = ON, 
CHECK_EXPIRATION = OFF 

-- Login: bb_bb60 

CREATE LOGIN [bb_bb60] WITH PASSWORD = 
0x0100CFDEDFD72728293B7BA10707E744719530FD087568063184 HASHED, 
SID = 0x30F13A5E6DBD384BAE4052EF3819DA7F, CHECK_POLICY = ON, 
CHECK_EXPIRATION = OFF 

-- Login: bb_bb60_stats 

CREATE LOGIN [bb_bb60_stats] WITH PASSWORD = 
0x0100EC250293C8A222C52E686C86978B85ADF399CB2FDC92133B HASHED, 
SID = 0x6B863053E4529445A765230019A6CF8B, CHECK_POLICY = ON, 
CHECK_EXPIRATION = OFF 

-- Login: bb_bb60_report 

CREATE LOGIN [bb_bb60_report] WITH PASSWORD = 
0x0100B8CBFFA2EAFD162E86DD247A65B5BAEEB528C899A168F7A6 HASHED, 
SID = 0x595104BF8945C242B15DC0442A48F424, CHECK_POLICY = ON, 
CHECK_EXPIRATION = OFF  

-- Login: cms_user 

CREATE LOGIN [cms_user] WITH PASSWORD = 
0x01009257460319A944DBA70944B1F16A710C9EC6F04602FAD6C4 HASHED, 
SID = 0x13A660C6B9A2BC4495AF3582D3B75496, CHECK_POLICY = ON, 
CHECK_EXPIRATION = OFF 

 

6. Shutdown the SQL Server 2005 Instance.  
A. Right-click > My Computer > Manage 
B. Services and Applications > Services  
C. Right-click SQL Server (ENG2005) > Stop 
D. Also shut down the SQL Server Agent (ENG2005) service. 

 
7. Map a network drive to the destination server.  

 

net use z: \\%DST_DB_SERVER%\public 
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8. Copy the database backup (and content) to the destination database server. For 
Windows Server 2003, the robocopy utility is part of the Windows Server 2003 Resource 
Kit Tools. 

a. One-server source, one-server destination. 

 

robocopy /E c:\sql_backup z:\sql_backup 

net use z: /delete 

 

b. One-server source, two-server destination; copy content. 

 

robocopy /E c:\blackboard\content z:\bb_content 

robocopy /E c:\sql_backup z:\sql_backup 

net use z: /delete 

 

c. Two-server source, two-server destination; copy content. 

 

robocopy /E c:\bb_content z:\bb_content 

robocopy /E c:\sql_backup z:\sql_backup 

net use z: /delete 
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Restore the Database on the Destination Server 
If you have a full Blackboard license which includes the Learning System, the Content System, 
the Community System and the Outcomes System, then there are 10 schemas and 5 users to 
restore. If you do not have all of these modules licensed, then there will be fewer schemas and 
users to restore and you should adjust these scripts as necessary.  

This work should be done as the Active Directory domain user that runs your Blackboard Learn 
instance (e.g. %DOMAIN%\blackboard), which has been granted administrative access to your 
servers. 

Warning: When doing work through the command line, be sure to run the Command Prompt as 
administrator (right-click, Run as administrator) or you may see permissions errors. 

1. Move the Blackboard Learn content and database files to the proper location: 

 
# move the content files, if they were copied to this server 
move c:\public\bb_content c:\ 
 
# move the database backup files 
move c:\public\sql_backup c:\ 
 

2. Shut down the public CIFS file share. 

 
net share public /delete 
 

3. Create the bb_content CIFS file share, if this is a two-server configuration. 

 
net share bb_content=c:\bb_content /grant:%DOMAIN%\blackboard,FULL 
 

4. Create the c:\blackboard\mssql directory structure.  

 
mkdir c:\blackboard\mssql\data 
 

5. Restore the database.  
A. Start SQL Server Management Studio, log in as the "sa" administrator user and 

connect to the Blackboard instance (e.g. ENG2008). 
B. Restore the databases from the backup files in c:\sql_backups.  
C. New Query > Execute  

RESTORE DATABASE bb_bb60 FROM DISK = 
'c:\sql_backup\bb_bb60.bak' WITH 
MOVE 'bb_bb60_data' TO 'c:\bb_data\data\bb_bb60.mdf', 
MOVE 'bb_bb60_log' TO 'c:\bb_data\logs\bb_bb60_log.ldf', 
REPLACE 
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RESTORE DATABASE bb_bb60_stats FROM DISK = 
'c:\sql_backup\bb_bb60_stats.bak' WITH 
MOVE 'bb_bb60_stats_data' TO 
'c:\bb_data\data\bb_bb60_stats.mdf', 
MOVE 'bb_bb60_stats_log' TO 
'c:\bb_data\logs\bb_bb60_stats_log.ldf', 
REPLACE 
 
RESTORE DATABASE bbadmin FROM DISK = 
'c:\sql_backup\bbadmin.bak' WITH 
MOVE 'bbadmin_data' TO 'c:\bb_data\data\bbadmin.mdf', 
MOVE 'bbadmin_log' TO 'c:\bb_data\logs\bbadmin_log.ldf', 
REPLACE 
 
RESTORE DATABASE cms FROM DISK = 'c:\sql_backup\cms.bak' 
WITH 
MOVE 'cms_data' TO 'c:\bb_data\data\cms.mdf', 
MOVE 'cms_log' TO 'c:\bb_data\logs\cms_log.ldf', 
REPLACE 
 
RESTORE DATABASE cms_doc FROM DISK = 
'c:\sql_backup\cms_doc.bak' WITH 
MOVE 'cms_doc_data' TO 'c:\bb_data\data\cms_doc.mdf', 
MOVE 'cms_doc_log' TO 'c:\bb_data\logs\cms_doc_log.ldf', 
REPLACE 
 
RESTORE DATABASE cms_files_courses FROM DISK = 
'c:\sql_backup\cms_files_courses.bak' WITH 
MOVE 'cms_files_courses_data' TO 
'c:\bb_data\data\cms_files_courses.mdf', 
MOVE 'cms_files_courses_log' TO 
'c:\bb_data\logs\cms_files_courses_log.ldf', 
REPLACE 
 
RESTORE DATABASE cms_files_inst FROM DISK = 
'c:\sql_backup\cms_files_inst.bak' WITH 
MOVE 'cms_files_inst_data' TO 
'c:\bb_data\data\cms_files_inst.mdf', 
MOVE 'cms_files_inst_log' TO 
'c:\bb_data\logs\cms_files_inst_log.ldf', 
REPLACE 
 
RESTORE DATABASE cms_files_library FROM DISK = 
'c:\sql_backup\cms_files_library.bak' WITH 
MOVE 'cms_files_library_data' TO 
'c:\bb_data\data\cms_files_library.mdf', 
MOVE 'cms_files_library_log' TO 
'c:\bb_data\logs\cms_files_library_log.ldf', 
REPLACE 
 
RESTORE DATABASE cms_files_orgs FROM DISK = 
'c:\sql_backup\cms_files_orgs.bak' WITH 
MOVE 'cms_files_orgs_data' TO 
'c:\bb_data\data\cms_files_orgs.mdf', 
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MOVE 'cms_files_orgs_log' TO 
'c:\bb_data\logs\cms_files_orgs_log.ldf', 
REPLACE 
 
RESTORE DATABASE cms_files_users FROM DISK = 
'c:\sql_backup\cms_files_users.bak' WITH 
MOVE 'cms_files_users_data' TO 
'c:\bb_data\data\cms_files_users.mdf', 
MOVE 'cms_files_users_log' TO 
'c:\bb_data\logs\cms_files_users_log.ldf', 

D. Restore the Blackboard Learn database logins from the backup file 
c:\sql_backups\create_login.txt; you will copy and paste the contents of 
this file into the query console. The values provided below are only an example.  
New Query > Execute  

-- Login: bbadmin 
CREATE LOGIN [bbadmin] WITH PASSWORD = 
0x01009B0B2830D545616B065BBCAEAE2F4AA80C7A906245034D2D 
HASHED, SID = 0x5769680D7874044A8FA68762FF01E9FB, 
CHECK_POLICY = ON, CHECK_EXPIRATION = OFF 
  
-- Login: bb_bb60 
CREATE LOGIN [bb_bb60] WITH PASSWORD = 
0x0100CFDEDFD72728293B7BA10707E744719530FD087568063184 
HASHED, SID = 0x30F13A5E6DBD384BAE4052EF3819DA7F, 
CHECK_POLICY = ON, CHECK_EXPIRATION = OFF 
  
-- Login: bb_bb60_stats 
CREATE LOGIN [bb_bb60_stats] WITH PASSWORD = 
0x0100EC250293C8A222C52E686C86978B85ADF399CB2FDC92133B 
HASHED, SID = 0x6B863053E4529445A765230019A6CF8B, 
CHECK_POLICY = ON, CHECK_EXPIRATION = OFF 
  
-- Login: bb_bb60_report 
CREATE LOGIN [bb_bb60_report] WITH PASSWORD = 
0x0100B8CBFFA2EAFD162E86DD247A65B5BAEEB528C899A168F7A6 
HASHED, SID = 0x595104BF8945C242B15DC0442A48F424, 
CHECK_POLICY = ON, CHECK_EXPIRATION = OFF 
  
-- Login: cms_user 
CREATE LOGIN [cms_user] WITH PASSWORD = 
0x01009257460319A944DBA70944B1F16A710C9EC6F04602FAD6C4 
HASHED, SID = 0x13A660C6B9A2BC4495AF3582D3B75496, 
CHECK_POLICY = ON, CHECK_EXPIRATION = OFF 

E. Set the default database for each Blackboard Learn database login.  
New Query > Execute  

EXEC master..sp_defaultdb bb_bb60, bb_bb60 
EXEC master..sp_defaultdb bb_bb60_report, bb_bb60 
EXEC master..sp_defaultdb bb_bb60_stats, bb_bb60_stats 
EXEC master..sp_defaultdb bbadmin, bbadmin 
EXEC master..sp_defaultdb cms_user, cms 
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F. Reconfigure the Blackboard Learn parameters within the restored database. 
%DST_APP_HOSTNAME% should be replaced with the unqualified hostname of 
the destination application server, %DST_DB_HOSTNAME% should be replaced 
with the unqualified hostname of the destination database server, 
%DB_INSTANCE% should be replaced with your database instance name and 
%DOMAIN% should be replaced with your DNS domain name.  
New Query > Execute  

update bbadmin.dbo.BB_CONFIG_REGISTRY set HOSTNAME = 
'%DST_APP_HOSTNAME%'; 
update bbadmin.dbo.BB_INSTANCE set DB_HOST = 
'%DST_DB_HOSTNAME%'; 
update bbadmin.dbo.BB_INSTANCE set DB_INSTANCE = 
'%DB_INSTANCE%'; 
update bbadmin.dbo.BB_INSTANCE set STAT_DB_HOST = 
'%DST_DB_HOSTNAME%'; 
update bbadmin.dbo.BB_INSTANCE_HOST set HOSTNAME = 
'%DST_APP_HOSTNAME%.%DOMAIN%'; 
 
update cms.dbo.XY_FILE_SYSTEMS 
 set JDBC_CONNECTION_URL = 
'jdbc:inetdae7:%DST_DB_HOSTNAME%.%DOMAIN%\%DB_INSTANCE%:143
3?database=cms_files_users&secureLevel=0' 
 where DISPLAY_NAME = 'cms_files_users'; 
update cms.dbo.XY_FILE_SYSTEMS 
 set JDBC_CONNECTION_URL = 
'jdbc:inetdae7:%DST_DB_HOSTNAME%.%DOMAIN%\%DB_INSTANCE%:143
3?database=cms_files_courses&secureLevel=0' 
 where DISPLAY_NAME = 'cms_files_courses'; 
update cms.dbo.XY_FILE_SYSTEMS 
 set JDBC_CONNECTION_URL = 
'jdbc:inetdae7:%DST_DB_HOSTNAME%.%DOMAIN%\%DB_INSTANCE%:143
3?database=cms_files_orgs&secureLevel=0' 
 where DISPLAY_NAME = 'cms_files_orgs'; 
update cms.dbo.XY_FILE_SYSTEMS 
 set JDBC_CONNECTION_URL = 
'jdbc:inetdae7:%DST_DB_HOSTNAME%.%DOMAIN%\%DB_INSTANCE%:143
3?database=cms_files_inst&secureLevel=0' 
 where DISPLAY_NAME = 'cms_files_inst'; 
update cms.dbo.XY_FILE_SYSTEMS 
 set JDBC_CONNECTION_URL = 
'jdbc:inetdae7:%DST_DB_HOSTNAME%.%DOMAIN%\%DB_INSTANCE%:143
3?database=cms_files_library&secureLevel=0' 
 where DISPLAY_NAME = 'cms_files_library'; 
update cms.dbo.XY_FILE_SYSTEMS 
 set JDBC_CONNECTION_URL = 
'jdbc:inetdae7:%DST_DB_HOSTNAME%.%DOMAIN%\%DB_INSTANCE%:143
3?database=cms_doc&secureLevel=0' 
 where DISPLAY_NAME = 'cms_doc'; 
 
# update content system storage locations, if this is a 
one-server to two-server scenario 
update cms.dbo.XY_STORAGE_LOCATIONS 
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 set WINDOWS_STORAGE_LOCATION = 
'//%DST_DB_HOSTNAME%/bb_content/storage/users' 
 where STORAGE_LOCATION_ID = 1001; 
update cms.dbo.XY_STORAGE_LOCATIONS 
 set WINDOWS_STORAGE_LOCATION = 
'//%DST_DB_HOSTNAME%/bb_content/storage/courses' 
 where STORAGE_LOCATION_ID = 1002; 
update cms.dbo.XY_STORAGE_LOCATIONS 
 set WINDOWS_STORAGE_LOCATION = 
'//%DST_DB_HOSTNAME%/bb_content/storage/orgs' 
 where STORAGE_LOCATION_ID = 1003; 
update cms.dbo.XY_STORAGE_LOCATIONS 
 set WINDOWS_STORAGE_LOCATION = 
'//%DST_DB_HOSTNAME%/bb_content/storage/institution' 
 where STORAGE_LOCATION_ID = 1004; 
update cms.dbo.XY_STORAGE_LOCATIONS 
 set WINDOWS_STORAGE_LOCATION = 
'//%DST_DB_HOSTNAME%/bb_content/storage/library' 
 where STORAGE_LOCATION_ID = 1005; 
update cms.dbo.XY_STORAGE_LOCATIONS 
 set WINDOWS_STORAGE_LOCATION = 
'//%DST_DB_HOSTNAME%/bb_content/storage' 
 where STORAGE_LOCATION_ID = 1101; 
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Restore the Application on the Destination Server 
This work should be done as the Active Directory domain user that runs your Blackboard Learn 
instance (e.g. DOMAIN\blackboard), which has been granted administrative access to your 
servers. 

 Warning: When doing work through the command line, be sure to run the Command Prompt as 
administrator (right-click, Run as administrator) or you may see permissions errors. 

1. Move the Blackboard Learn files to the proper location. 
 
move c:\public\blackboard c:\ 

 
2. Shut down the public CIFS file share.  

 
net share public /delete 
 

3. Reconfigure Blackboard Property Files.  
a. The property and configuration files that have a corresponding file with a *.bb 

extension will be regenerated by PushConfigUpdates. 
b. %DST_APP_HOSTNAME% should be replaced with the unqualified hostname of 

the destination application server, %DST_DB_HOSTNAME% should be replaced 
with the unqualified hostname of the destination database server, 
%DB_INSTANCE% should be replaced with your database instance name and 
%DOMAIN% should be replaced with your DNS domain name. 

c. File: c:\blackboard\apps\isapi\bb-odbc.ini  

Property Purpose 
odbc.db.instance = %DB_INSTANCE% Update SQL Server instance name 
odbc.db.server = 
SERVER=%DST_DB_HOSTNAME%.%DOMAIN% Update server name  

d. File: c:\blackboard\apps\xythos\xythos.properties 

Property Purpose 
Xythos.BaseJDBCConnectionURL= 
jdbc:inetdae7:%DST_DB_HOSTNAME%.%DOM
AIN% 
\\%DB_INSTANCE%:1433?database=cms&se
cureLevel=0 

Update server name and SQL Server 
instance name. Note that this is a 
single line in the file; it was broken 
up here for readability. 

e. File: c:\blackboard\config\bb-config.properties  
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Property Purpose 
bbconfig.java.home=C:/jdk1.6.0_30 Update JDK location, if necessary 
bbconfig.java.home.win=C:\\jdk1.6.0_
30 Update JDK location, if necessary 

bbconfig.base.shared.dir=//%DST_DB_H
OSTNAME%/bb_content Check the shared content location 

bbconfig.base.shared.dir.win=\\\\%DS
T_DB_HOSTNAME%\\bb_content Check the shared content location 

bbconfig.webserver.fullhostname=%DST
_APP_HOSTNAME%.%DOMAIN% 

Set the webserver hostname, fully 
qualified 

bbconfig.appserver.fullhostname=%DST
_APP_HOSTNAME%.%DOMAIN% 

Set the appserver hostname, fully 
qualified 

bbconfig.appserver.machinename=%DST_
APP_HOSTNAME% 

Set the appserver machinename, 
unqualified 

bbconfig.appserver.domainname=%DOMAI
N% Set the appserver domainname 

bbconfig.smtpserver.hostname=%SMTP_H
OSTNAME%.%DOMAIN% 

Update the SMTP server, if 
necessary, fully qualified 

bbconfig.collabserver.fullhostname.d
efault=%DST_APP_HOSTNAME%.%DOMAIN% 

Set the collabserver hostname, fully 
qualified 

bbconfig.platform.64bit=true Set the platform to 64bit 
bbconfig.platform.libdir=lib64 Set the libdir to 64bit 
(9.0) 
bbconfig.database.server.systemuserp
assword=$PASSWORD 

(8.0) 
bbconfig.database.bbadmin.machine.sy
stemuserpassword=$PASSWORD 

Check the database systemuser 
password 

(9.0) 
bbconfig.database.datadir=C:/blackbo
ard/mssql/data 

(8.0) 
bbconfig.database.bbadmin.db.datadir
=C:/blackboard/mssql/data 

Check the database data directory  

(9.0) 
bbconfig.database.datadir.win=C:\\bl
ackboard\\mssql\\data 

(8.0) 
bbconfig.database.bbadmin.db.datadir
.win=C:\\blackboard\\mssql\\data 

Check the database data directory  

(9.0) 
bbconfig.database.server.name=%DST_D
B_HOSTNAME% 

(8.0) 

Set the database server hostname, 
unqualified  
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Property Purpose 
bbconfig.database.bbadmin.machine.ma
chinename=%DST_DB_HOSTNAME% 
(9.0) 
bbconfig.database.server.fullhostnam
e=%DST_DB_HOSTNAME%.%DOMAIN% 

(8.0) 
bbconfig.database.bbadmin.machine.fu
llhostname=%DST_DB_HOSTNAME%.%DOMAIN
% 

Set the database server hostname, 
fully qualified  

(9.0) 
bbconfig.database.server.instancenam
e=%DB_INSTANCE% 

(8.0) 
bbconfig.database.bbadmin.machine.in
stancename=%DB_INSTANCE% 

Set the database server instance 
name  

bbconfig.database.stats.server.name=
%DST_DB_HOSTNAME%.%DOMAIN% 

Set the database stats server 
hostname, fully qualified  

(9.0) 
bbconfig.database.logdir.mssql=C:\\b
lackboard\\mssql\\data 

(8.0) 
bbconfig.database.bbadmin.db.mssql.l
ogdir.win=C:\\blackboard\\mssql\\dat
a 

Check the database log directory  

(9.0) 
bbconfig.database.indexdir.oracle=C:
/blackboard/mssql/data 

(8.0) 
bbconfig.database.bbadmin.db.oracle.
indexdir=C:/blackboard/mssql/data 

Check the database index directory  

bbconfig.appserver.service.account.w
in=%AD_DOMAIN%\\%USERNAME% 

Check the Active Directory domain 
user that will run the appserver  

bbconfig.appserver.service.password.
win=%PASSWORD% 

Check the password for the Active 
Directory domain user  

bbconfig.collabserver.service.accoun
t.win=%AD_DOMAIN%\\%USERNAME% 

Check the Active Directory domain 
user that will run the collabserver  

bbconfig.collabserver.service.passwo
rd.win=%PASSWORD% 

Check the password for the Active 
Directory domain user  

bbconfig.cs.external.data.courses=//
%DST_DB_HOSTNAME%/bb_content/storage
/courses 

Set the courses shared content 
location  

bbconfig.cs.external.data.inst=//%DS
T_DB_HOSTNAME%/bb_content/storage/in
stitution 

Set the institution shared content 
location  

bbconfig.cs.external.data.library=// Set the library shared content 
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Property Purpose 
%DST_DB_HOSTNAME%/bb_content/storage
/library 

location  

bbconfig.cs.external.data.orgs=//%DS
T_DB_HOSTNAME%/bb_content/storage/or
gs 

Set the orgs shared content location  

bbconfig.cs.external.data.users=//%D
ST_DB_HOSTNAME%/bb_content/storage/u
sers 

Set the users shared content location  

bbconfig.cs.external.storage.locatio
n=//%DST_DB_HOSTNAME%/bb_content/sto
rage 

Set the storage shared content 
location  

bbconfig.cs.db.systemuser.pass=$PASS
WORD 

Check the database systemuser 
password 

f. File: c:\blackboard\tools\admin\PushConfigUpdates.bat  

Property Purpose 
set JAVA_HOME=C:\jdk1.6.0_30 Update JDK location, if necessary 

 

4. Update the Blackboard configuration by running PushConfigUpdates.  
A. This will push the bb-config.properties updates to the appropriate files, create the 

Bb-Collab service running as your domain user, create the Bb-Tomcat service 
running as your domain user and create the blackboard_bb_bb60 website within 
IIS.  
C:\blackboard\tools\admin\PushConfigUpdates.bat 
 

5. Import your SSL certificate from the PFX file in c:\public\ssl_backup\ssl_cert.pfx, 
if you have one.  

a. Right-click Computer > Manage 
b. Server Manager > Roles > Web Server (IIS) > Internet Information Services (IIS) 

Manager 
c. Connections > %HOSTNAME% > Features View > Server Certificates > Import... 
d. Certificate file (.pfx): c:\public\ssl_backup\ssl_cert.pfx > Password: 

%PASSWORD% > Check: Allow this certificate to be exported > Ok 
e. Connections > %HOSTNAME% > Sites > right-click blackboard_bb_bb60 > Edit 

bindings... 
f. Add... > Type: https > IP Address: All Unassigned > Port: 443 > SSL Certificate: 

%CERTIFICATE% > Ok 
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Upgrade the Application on the Destination Server 
1. Run the Blackboard installer jar to upgrade the application.  

$JAVA_HOME/bin/java -jar bb-as-windows-9.1.82223.0.jar 

 


