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Introduction 

About the Release Notes 

The Release Notes provide Instructors with information about new features and enhancements. 
This includes information on browser compatibility, new feature descriptions, and changes to the 
system from the previous release. 

What is in the Release Notes? 

The Release Notes contain the following sections: 

• New Features and Enhancements – Describes new features in this release, additional 
important enhancements that have been made to the system, and how to enable or 
disable these features. 

• End User Compatibility Matrix – Reviews which end-user browsers and operating 
systems are supported with this release.  

• Reference materials – Lists and describes reference manuals available for this release. 
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New Features and Enhancements 

Overview 

In response to user feedback,Blackboard Academic Suite™, Release 8, introduces a number of 
new features and enhancements to the existing features. 

This section reviews the new features in Release 8, explains their default availability upon 
installation, and specifies Blackboard license requirements. 

New features and enhancements fall into the following categories: 

• Grade Center 

• Self and Peer Assessment Building Block™ 

• SafeAssign™ 

• Blackboard Content System™ Enhancements 

• Scholar™ Building Block for Basic 
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Grade Center 

Overview 

Almost entirely redesigned, and newly named, the Grade Center exhibits new capabilities and 
vast improvements over the previous Gradebook. Some of the new features or improvements 
include the following: 

• A redesigned tool bar, titled the Action Bar, through which multiple functions are 
possible 

• The ability to create and print Reports, such as final grades, to hand out toStudents or 
other interested parties 

• Inline editing: the ability to enter grades directly through the Grade Center 
spreadsheet 

• New grade calculations, Average grade and Minimum/Maximum grade, and 
improvements to the creation of Weighted grades and Total points grade 

• Smart Views -- the ability to categorize Students into groupings based onselected 
criteria. These views can be displayed in the Grade Center. 

• A multitude of ways to customize the display of the Grade Center 

• The ability to create Grading Schema: multiple grading scales that match Assessment 
grades to chosen grade displays, such as text or percent grades 

Grade Center main page 

The Action Bar on the Grade Center main page contains multiple functions, including the 
following: 

• Adding columns 

• Managing Grading Periods 

• Grading Schema 

• Smart Views 

• Emailing Students 

• Creating Reports 

• Viewing Grade History 
  

Within the Grade Center spreadsheet, it is possible to enter results, such as scores, percentages, 
or other forms of grading, into the spreadsheet itself.  

In the various Columns, cells, and rows, the Instructor can quickly perform multiple functions that 
formerly required multiple clicks and subsequent navigation to other pages.  
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Reports  

Through the Grade Center, an Instructor may create a Report that displays various grade and 
Student information. A Report could be used, for example, as a final grade Report or a mid-term 
progress report. The Instructor can control what grades are displayed in the Report as well as 
what student information appears. A signature line and any comments can be added. Reports 
can then be printed from the screen and distributed.  

Grade Calculations 

In the Grade Center, an Instructor can calculate grades by combining multiple Columns to attain 
performance results, such as class averages, final grades that are based on a weighted scale, or 
total points, and so on. These include Weighted grade, Total points grade, Average grade, and 
Minimum/Maximum grade. Each of these functions allows the Instructor to choose the Columns 
included, such as all Columns from a Grading Period, all Columns, or selected Columns.  

Smart Views 

Instructors have the ability to customize the Grade Center to display a subset of Students based 
on selected criteria. Called Smart Views these customized displays can be saved and used 
again. Students can be sorted based on Course, Group, performance measurements, or other 
criteria. Once built and saved, Smart Views become a selectable list item on the Current View 
drop-down menu of the Grade Center page, enabling easy navigation from one view to another. 

Grading Schema 

Administrators and Instructors can create Grading Schema-- a diagram based on percentage 
ranges that matches scores to specific grade displays -- and then use it in grading. For example, 
a Student’s raw numeric score on a quiz that has 100 possible points is an 88. The Instructor 
creates and deploys a Grading Schematitled "Standard," in which a percentage of 87.5 to 89.5 
equals a B+, this score results in a B+. Conversely, if the grade display option Letter is chosen, 
the B+ will display to the Student. The Instructor can also choose text as the display option in 
Grading Schema. Grading Schemas may be edited or added to an ongoing Course and grades 
will be updated to reflect the changes. 
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Blackboard Content System Enhancements 

Collaboration (Workflows) 

New to the Blackboard Content System is the Collaboration page. Through this page, it is 
possible to create, initiate, and manage Workflows. A Workflow is a chronological collection of 
tasks that comprise a business process, an Assignment, or a collaborative project. Now, all 
Blackboard Content System users can create multi-stage Workflows, thereby creating tasks, 
defining task order, and managing the Workflow. This can all be managed through the 
Collaboration page.  

Workflows are comprised of Actions of Milestones. Actions are required steps that an assigned 
Workflow participant must complete before passing the Workflow onto the next assigned 
participant. These are designed by the Workflow Owner. The Workflow Owner also determines 
Milestones: goals in a Workflow that are reached through the completion of Actions.  

Workflows are deployed by using Models. A Model is a collection of Milestones and Actions that 
are pre-defined so a Workflow can be deployed quickly and easily. A model serves as the 
template for a Workflow: A single Model multiple Workflow can have occurrences and can be 
shared with other Content System users. Sharing these Models with the appropriate roles within 
an Institution can increase efficiency and accuracy.  

The Collaboration page provides users with the capability to do the following:  

• Get Started on a Workflow  

• Check the Progress of a Workflow 

• Design Models of a Workflow 

• Email Workflow participants 

• Create a To Do List that displays the Workflow Actions to which the user has been 
assigned.  

Metadata 

There are a number of enhancements to Blackboard Content System’s Metadata feature.  

Metadata is now integrated with the Blackboard Outcomes System’s Standards, Objectives, and 
Goals, wherein the Standards, Objectives, and Goals can be treated as Metadata and be used to 
align Content System items.  

Also, Metadata can now be linked to the creation of a Content Item. If configured, Metadata 
subsets are filled out upon Content item creation, facilitating precise records. When the Content 
item is created, the Metadata aligned with the Content item is displayed.  

360° View  

Improved in the Blackboard Content System for Release 8 is the 360° View, which is available for 
each Content item. Through the 360° View, users can view the properties located on various 
pages in the interface, the information on existing links to the item, and the Metadata information 
associated to the item.   
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Miscellaneous Enhancements 

There are numerous smaller enhancements to the Blackboard Content System. 

It is now possible for users to subscribe to a directory in the Blackboard Content System so that 
they are notified of any changes or updates to the directory.  

Any Content item created using any Visual Text Box Editor in theBlackboard Learning System 
can be saved as a Reusable Object. Reusable Objects can be used anywhere in the system and 
they use the same settings as other Content items. Users can select a storage location for 
Reusable Objects, and they may be copied and reused just as other Content System Items. 

Administrators can set the local file upload to require users to upload content to Content 
Collection.  

Advanced System Reporting 

Advanced System Reporting enables an Institution to do robust reporting to understand how its 
system is being used. Data from predefined fields in a separate database is used to create and 
tailor reports to meet specific needs. These reports assist in understanding and analyzing use of 
the system and can report information such as when different types of users access the system, 
how they use the system, and if the system improves Student performance. Librarians can 
discover how Content System Items are being used, including information such as how many 
links exist to each Item, from which Courses, the frequency of access to those items, and the last 
date of access. 

These features and enhancements are available for the Blackboard Content System license. 
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SafeAssign 

Overview 

Release 8 features the new SafeAssign™, a tool that compares submitted Assignments against a 
set of academic essays to identify areas of overlap. SafeAssign can be used to prevent 
plagiarism and to create opportunities to help Students identify how to properly attribute sources 
rather than paraphrase.  

SafeAssign draws from several different databases: the Internet, ProQuest©, ABI/Inform© 
database, institutional document archives, and the Global Reference Database, which includes 
content submitted into SafeAssign from Blackboard-powered institutions.  

Please note that SafeAssign content must be created itself, and that previously created 
Assignments cannot be integrated with SafeAssign.  

SafeAssign is integrated with the Grade Center.  

SafeAssign is available as part of the Blackboard Learning System – Enterprise platform. 
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 Self and Peer Assessment Building Block 

Overview 

The new Self and Peer Assessment Building Block is a comprehensive and flexible tool for the 
self- and peer assessment of text, images, and digital-based resources within Blackboard 
Learning System. It allows an Instructor to create an exercise with a list of questions for the 
assessor. These questions can have a variety of grading or marking criteria, created or selected 
by the Instructor, to be used in the assessment.  

The Instructor then distributes the exercise with the questions and criteria to the Students. The 
Instructor can choose to have the Student assess his or her own work or the works of other 
Students. In turn, the Students submit the work, to be viewed by the Instructor. The Instructor can 
monitor the progress of the assessment, download the assessment submission and results, and 
add the assessment marking to the Grade Center. 
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Blackboard Scholar Integration with Blackboard Learning 
System – Basic  

Overview 

Blackboard Scholar is a social bookmarking service customized for education. Social 
bookmarking is an activity performed over a computer network that allows users to save and 
categorize a personal collection of bookmarks -- stored or retrievable web pages -- and share 
them with others. It provides a new way for Students and Instructors to find educational resources 
on the Web for Courses and research. Furthermore, by storing and sharing associated 
information with each resource through tags and disciplines, Scholar allows users to evaluate the 
resources and find the most relevant and reliable. 

Scholar is directly integrated within the Blackboard Learning System™ - Enterprise, Vista, and 
CE Licenses, providing access within the Course environment. 
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 Blackboard Academic Suite Changes
 The table below lists the functional changes in Blackboard Academic Suite8.  

 Component – 
Subsystem/ 
License 

Change/New Feature Descript ion 
  

Grade Center 
All Licenses 

Various New Features and Changes The Grade Center has vast 
changes and additions. For 
more information, see the 
Instructor Manual.  

Collaboration 
(Workflows) 
Blackboard 
Content System 
license 

New Feature Collaboration and 
Workflows have various 
new features, and 
enhancements. For more 
information, see the 
Blackboard Content System 
User Manual.  

SafeAssign 
Blackboard 
Learning 
System – 
Enterprise 
license 

Instructor Control Panel: from any Course 
Content Page, in the Select: drop-down 
menu>SafeAssign

Add a SafeAssignment to 
the Course.  

SafeAssign 
Blackboard 
Learning 
System – 
Enterprise 
license 

Instructor Control Panel: Course 
Tools>SafeAssign

Displays the page for 
managing and viewing 
SafeAssignments created 
for the Course.  

SafeAssign 
Blackboard 
Learning 
System – 
Enterprise 
license 

Instructor Control Panel: Course 
Tools>SafeAssign>SafeAssignments 
tab 

Displays the 
SafeAssignments created 
for the Course and their 
corresponding information.  

SafeAssign 
Blackboard 
Learning 
System – 
Enterprise 
license 

Instructor Control Panel: Course 
Tools>SafeAssign>Direct Submit tab 

Direct Submit generates 
SafeAssign reports on 
papers submitted outside of 
a SafeAssignment and it 
may also be used to add 
papers to the institutional 
database.   

SafeAssign 
Blackboard 
Learning 
System – 
Enterprise 
license 

Students: Any Course Content area: 
select a SafeAssignment 

Submit to a 
SafeAssignment.  
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 Component – 
Subsystem/ 
License 

Change/New Feature Descript ion 
  

Course Content 
– Add Item, 
Metadata 
Blackboard 
Content System 
license 

Content area: Add Item>Submit and Add 
Metadata 

Link Metadata Attributes to 
a Content item. 

Course Content 
– Metadata 
Blackboard 
Content System 
license 

Content area: Add Item>Submit and Add 
Metadata>Keep these Values 
synchronized

If there are changes to the 
Metadata, this will be 
reflected in the Content 
items associated to it.  

Content 
Collection – 
Metadata 
Blackboard 
Content System 
license 

Content Area folder or subfolder: Modify 
Folder> Permissions

Subscribe to a Folder.  

Course Content 
item 
Blackboard 
Content System 
license 

Control Panel>Content Collection>360° 
View

  

View the properties located 
on various pages in the 
interface, the information on 
existing links to the item, 
and the Metadata 
information associated to 
the item, among other 
information.  

Course Content 
Blackboard 
Content System 
license 

Save as Reusable Object Save a newly created 
Course Item as an Item in 
the Content Collection.  

All Content 
Areas 

Self and Peer Assessment Create a Self or Peer 
Assessment for a Course or 
to be stored in the Content 
area.  

All Content 
Areas 

Self or Peer Assessment: 
Modify>Assessment Canvas

View and modify 
Assessment questions and 
evaluation criteria. Preview 
the submission page or the 
evaluation page for the 
assessment 

All Content 
Areas 

Self or Peer Assessment: 
Modify>Properties

Modify the properties, 
instructions, availability, and 
evaluation options of a Self 
or Peer Assessment.  

All Content 
Areas 

Self or Peer Assessment: Modify>Export 
Assessment

Export an Assessment as a 
file that can be reused and 
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 Component – 
Subsystem/ 
License 

Change/New Feature Descript ion 
  

shared.  

All Content 
Areas 

Self or Peer Assessment: 
Modify>Assessment Canvas>Question

Add a Question to a Self or 
Peer Assessment Exercise. 

All Content 
Areas 

Self or Peer Assessment: 
Modify>Assessment 
Canvas>Question>Criteria

Add Criteria to the 
Questions for a Self or Peer 
Assessment.  

All Content 
Areas 

Self or Peer Assessment: 
Modify>Assessment 
Canvas>Question>Modify

Modify the Questions for a 
Self or Peer Assessment.  
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End User Configuration Matrix 

End User Configuration Guidelines 

End users must use a certified or compatible operating system and browser configuration with the 
Blackboard Academic Suite. 

 Browser Windows 
XP 

Windows 
Vista 
Desktop 

Mac 10.3 Mac 10.4 Mac 10.5 

Microsoft 
Internet 
Explorer 6

Compatible Certified Not Tested Not Tested Not Tested 

Microsoft 
Internet 
Explorer 7

Compatible Certified Not Tested Not Tested Not Tested 

Mozilla Firefox 
1.5

    Compatible Certified Not Tested 

Mozilla Firefox 
2.0

Certified Certified Not Tested Certified Not Tested 

Apple Safari 2 Not Tested Not Tested Not Tested Certified Certified 

Apple Safari 3 Not Tested Not Tested Not Tested Compatible Compatible 

  

Key 

Certified fully tested and supported 

Compatible key application areas tested 

 Not tested specified Browser is not supported for the Operating System 
 
Provisional will test on Beta versions of new platforms and browsers. Certification is 

dependant on release by 3rd parties 

  
* All configurations marked as Compatible and have undergone a limited engineering analysis to 
test areas of the Blackboard Academic Suite that may have browser issues. 
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Reference Materials 

About Reference Materials 

A full suite of reference materials is available with the Academic Suite. All materials are located in 
the Reference Center at http://behind.blackboard.com. These materials include the following: 

Manual 
Name 

Descript ion 

Outcomes 
Manual

This provides information and instructions on the usage and capabilities of 
the Outcomes System. 

Blackboard Academic Suite End User Manuals  

User Manual Reference manual detailing the tools and functions included in the platform 
from the general user perspective. This manual includes information on the 
Blackboard Learning System and the Blackboard Community System. 

Instructor 
Manual

Reference manual providing detailed information about building and 
managing Courses and Organizations. This manual includes information on 
the Blackboard Learning System and the Blackboard Community System. 

Blackboard Content System End User Manuals  

User Manual Reference manual detailing the tools and functions included in the system for 
all end users. This manual includes information on the Blackboard Content 
System. 
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