
Version 11

Elluminate Plan! v2.1
User's Guide
December, 2011





Table of Contents

Page i

Preface 1

Audience 1

How to Use this Guide 1

Conventions Used in this Guide 2

Operating System Differences 2

Variables 2

Notes 3

Typographical Conventions 3

Help and Resources 4

Documentation and Training Materials 4

Technical Support 4

Community 4

Product Feedback 4

Chapter 1 Using the Session Plan Editor 5

Product Overview 5

The .elpx File 6

The Building Blocks of a Session Plan: Items 6

User Roles and Responsibilities 7

The Plan! User Interface 8



Moving Between Editors 8

The Plan Editor 9

The Whiteboard Editor 11

The Quiz Editor 12

Launching and Exiting Elluminate Plan! 13

Pre-Launch Configuration: Setting Your Language 13

Launching Elluminate Plan! 13

Exiting Elluminate Plan! 15

Working with Session Plan (.elpx) Files 16

Creating a New Session Plan 16

Opening an Existing Session Plan 16

Printing a Session Plan 17

Saving a Session Plan 17

Creating a Session Plan 18

Adding Content Files 18

Adding Topics 28

Adding Actions 30

Adding Text Items 41

Working with Session Plan Items 42

Setting Session Plan Properties 45

Validating Your Session Plan 48

Setting Elluminate Plan! Preferences 49

Application Preferences 50

Session Plan Preferences 51

Whiteboard Preferences 52

Creating Content within Elluminate Plan! 53

Creating a Whiteboard File 53

Creating a Quiz File 55

Chapter 2 Conducting a Session Using a Session Plan 57

Product Overview 57

The Session Plan Window 58

Library View – the Session Plan Library 58

Plan Outline View – the Plan Outline 59

Opening the Session Plan Window 61

ii Table of Contents



Changing Views 62

Switching to the Minimal Toolbar 62

Closing and Reopening the Session Plan Window 63

Blackboard Collaborate Menu Items 63

File Menu 63

Tools Menu 63

Window Menu 63

Working with Session Plans in the Session Plan Library 64

Loading Session Plans into the Library 64

Renaming Session Plans 64

Saving Session Plans 65

Printing Session Plans 65

Closing Session Plans 66

Removing Session Plans from the Library 66

Saving Embedded Files 66

Activating a Session Plan 67

Displaying a Session Plan to Participants 67

Running a Session Plan 68

Moving Through Session Plan Items 69

Tracking Your Progress 70

Duration Timers 71

Presenter Notes 72

Control of the Session Plan 72

Requesting/Relinquishing Control of the Session Plan 72

Controlling the Session Plan from a Breakout Room 73

When the Presenter Leaves the Session 73

Setting Session Plan Properties 74

Setting Your Preferences 74

Display Settings 75

Viewing Options 76

Session Plans and Recordings 77

Appendix A: Getting Help 79

Appendix B: Rules for Inserting and Indenting Session Plan Items 81

Inserting New Items 82

iiiTable of Contents



Moving Items 84

Appendix C: Supported Commands 87

Copyright 95

Trademarks 96

iv Table of Contents



Preface

Page 1

Audience
This guide is written for Blackboard Collaborate Web Conferencing® users who wish to use Ellu-
minate Plan!™ to create session plans for Blackboard Collaborate sessions. Typical users would
be course designers, instructors or other content providers who use Blackboard Collaborate to
offer a set curriculum, or any Blackboard Collaborate users who wants to prepare frameworks to
guide them through sessions.

How to Use this Guide
This guide consists of two chapters, as well as supplementary information:

n To create a new session plan (or edit an existing plan), refer to Chapter 1, “Using the Ses-
sion Plan Editor”.

n To use an existing session plan in Blackboard Collaborate, refer to Chapter 2, “Conducting
a Session Using a Session Plan”.

n To get help with Elluminate Plan!, refer to Appendix A, “Getting Help”.

n For detailed information on the rules that govern the placement and indentation of items
in a session plan, see Appendix B, “Rules for Inserting and Indenting Session Plan
Items”.



n For a list of Elluminate Plan! commands (Actions), and how a few of them differ from the
Blackboard Collaborate implementation of commands, refer to Appendix C, “Supported
Commands”.

Conventions Used in this Guide

Operating System Differences
This guide is written for Elluminate Plan! users on all supported operating systems: Windows,
Mac OS X, Linux and Solaris.

Keystrokes and Mouse Clicks

The same keystrokes and mouse clicks are used on Windows, Linux and Solaris platforms. Those
used on the Mac are different. This guide gives instructions for users of all supported operating
systems. The Windows/Linux/Solaris keystrokes or mouse clicks are given first, followed by
those for the Mac (in parentheses):

Mouse Click Example

Right-click (or Ctrl-Click on Mac) on an .elp or .elpx file and select Open from the context
menu.

Keystroke Example

To create a new session plan, press Ctrl+N (⌘N on Mac).

Screen Captures

Most screen captures shown in this guide were taken in a Windows environment. If you are run-
ning Elluminate Plan! on a Mac OS X, Solaris or Linux platform, the appearance of windows,
dialog boxes, etc. will differ slightly from those shown in this guide.

Variables
There are a few menus in Blackboard Collaborate and Elluminate Plan! that are populated with
data specific to the current context. Because we do not know in advance the names of certain
things (such as the name of something selected by the user), in this guide they are represented
by variables enclosed in angle brackets. For example, the variable <Module Name>] is used in
the discussion of Preferences to represent the name of the Module currently selected by the user
in the Preferences list.
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Notes
Six types of notes may be used in this guide to highlight information:

Note: Notes are used to highlight important information or to present
asides relevant to the topic at hand.

Tip: Tips provide helpful information on how to most effectively use a
particular feature of the product.

Caution: Cautions alert you to potentially confusing terminology or
difficulties that may occur when using the product.

Warning:Warnings alert you to potentially serious problems.

Notes of this format are used to highlight Linux-specific information.

Notes of this format are used to highlight Mac-specific information.

Typographical Conventions

Convention Description

1. Number Indicates a step in a task.

o Hollow bullets Indicates that there are several options available for completing a
task, but only one is necessary.

Bold Represents clickable elements in the user interface (e.g., text
links, buttons, tabs, etc.). Also used to give emphasis to words.

Italics Represents menu items, options and parameters. Also used for
cross references.

Monospace Indicates pathnames, filenames, folders and command lines.

<brackets> Indicates variables.
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Help and Resources

Documentation and Training Materials
Documentation and training materials (for all Blackboard Collaborate products) are available on
the On-Demand Learning Center, which can be reached as follows:

o In your browser, enter the following address:

http://www.blackboard.com/Platforms/Collaborate/Services/On-Demand-Learning-Center.aspx

Additional resources for Elluminate Plan! are listed in Appendix A, “Getting Help”.

Technical Support
Blackboard Collaborate technical support and the support Knowledge Base are available through
the Support Portal:

http://support.blackboardcollaborate.com

Community
We encourage Blackboard Collaborate users of all levels to join our Collaborati User's Group
(https://www.coursesites.com/s/_Collaborati), a new community in which users can share their
experiences, ideas, research, and best practices with their peers via forums and user-generated
blogs.

Product Feedback
Blackboard Collaborate welcomes your comments and suggestions. If you have an idea for a new
feature or enhancement, or would like to send other feedback, please send an email to
BBCollaborateFeedback@blackboard.com.

Your suggestion will be sent directly to our Product Management Team.
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Using the Session Plan Editor

Product Overview
Preparing for and conducting a Blackboard Collaborate Web Conferencing session involves a
number of tasks such as creating whiteboard screens and quizzes, gathering multimedia and
other files to be presented or shared, loading whiteboards and multimedia files into the session,
preparing an outline of topics, writing presenter notes and creating a list to remind you to per-
form specific actions (e.g., start recording, move to the next screen, create breakout rooms, load
and present a quiz, play a multimedia file, etc.).

Elluminate Plan! is a standalone desktop application that enables you to prepare the content of
a Blackboard Collaborate session ahead of time and then automate the actions within a session.
During the session, all it takes is the selection of a session plan item to trigger an action in Black-
board Collaborate (e.g., start recording, move to the next screen, create breakout rooms, load
and present a quiz, play a multimedia file, etc.). Topic headings and notes are embedded in the
session plan to provide cohesiveness and coherence to the material being presented.

Although it possesses much of the functionality of Blackboard Collaborate, Elluminate Plan!
operates independently of Blackboard Collaborate, allowing you to create session plans on a com-
puter without an Internet connection. Once you have created a session plan in Elluminate
Plan!, you can either manually load it into your Blackboard Collaborate session at class time or
preload it to appear automatically at the start of the session.1

1Preloading session plans is done through your Blackboard Collaborate scheduling server, either
the Session Administration System or ELM.



By automating many of the routine tasks of running sessions, session plans let presenters focus
on delivering the session material and interacting with session attendees. Elluminate Plan! also
provides course content providers (such as course designers) with the assurance that their con-
tent will be presented consistently by multiple presenters and across multiple sessions.

The .elpx File
Session plans are saved in Elluminate Plan! as .elpx files, which are loaded into and run within
Blackboard Collaborate sessions. All the session content (whiteboard files, files for transfer, mul-
timedia files and quizzes) is embedded in the .elpx file, along with the Plan Outline (which con-
sists of Topics, Text Items and Actions).

Plan files can be shared with others like any other file (e.g., copied, sent via email or published
on web sites for download).

The Building Blocks of a Session Plan: Items
There are four types of items that can be used to build a session plan: Topics, Text Items,
Actions and Embedded Files. Topics, Text Items and Actions (some of which reference Embed-
ded Files) can be added to the Plan Outline and then moved up or down and left or right relative
to one another (forming a hierarchy) to bring logic and cohesiveness to the session plan. Items
also can be renamed or deleted.

Embedded Files

The files embedded in a session plan tap into the existing functionality of Blackboard Col-
laborate. Any type of file can be embedded in a session plan but only quiz, multimedia and white-
board files are specifically recognized by Blackboard Collaborate and automatically associated
with their appropriate module (Quiz Manager, Multimedia Library and Whiteboard) in Black-
board Collaborate. Other file types (graphics, spreadsheets, documents, etc.) can be loaded into
the session plan, where they are automatically associated with file transfer to session attendees.

By default, all embedded files are loaded automatically into Blackboard Collaborate when the ses-
sion plan is activated in the session, effectively acting like a preload.

Note: An embedded file cannot directly be shared via Application Sharing
– files must reside on your desktop in order to be shared. For details, see
A Note on Embedding Files to be used for Application Sharing on
page 28.

When a session plan is saved, all embedded files are included in the saved file, making the ses-
sion plan entirely self-contained.
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Topics

Topics can be added to a session plan to group together a set of items and create a hierarchy of
your presentation. Topics can contain other Topics (subtopics) as well as Actions and Text
Items. Optionally, Topics can contain presenter notes and a suggested duration.

Text Items

Text Items are simple text strings that can be added to a session plan to enrich the content. They
are visible to everyone who can view the session plan. Optionally, Text Items can contain a sug-
gested duration.

Actions

Actions are items that trigger commands in Blackboard Collaborate. (See Appendix A, “Getting
Help” for a comprehensive list of Blackboard Collaborate commands available to Elluminate
Plan!) Actions contain a Description, Command Name and Command parameter values. Option-
ally, Actions can contain presenter notes and a suggested duration.

A special type of Action, a Compound Action, contains two or more sub-Actions to be
executed together in a single step. For example, a Compound Action might include a command
to create a breakout room and a command to distribute the session attendees to that room.
When running the session plan in Blackboard Collaborate, the presenter will be able to execute
only the compound action – not the sub-Actions. The sub-Actions can be displayed under their
“parent” Compound Action by clicking on the parent item’s icon.

User Roles and Responsibilities
There are three kinds of users who can interact with a session plan: the creator in Elluminate
Plan! and the presenter and the viewers in Blackboard Collaborate. In some cases, the creator
and the presenter will be the same person.

Creator: The creator is the person who creates the session plan and then (if the creator is
not also the presenter) forwards it to the presenter (via file sharing, email, web
download, etc.).

Presenter: The presenter is the person who runs the session plan during the live session. This
person must have Moderator privileges in Blackboard Collaborate. The privilege to
control a session plan can be exchanged between various Moderators.

The presenter loads the session plan into the Blackboard Collaborate session and
then interacts with the session plan by stepping through items one at a time, dis-
playing presenter notes and triggering Actions and Duration Timers as specified by
the session plan. Visual markers indicate progress through the plan.

7Using the Session Plan Editor



Viewers: The viewers are the session attendees who are allowed to view the session plan.
Moderators automatically have this privilege and Participants (as a group) must be
granted the viewing privilege by a Moderator. Participants can only view a session
plan and cannot interact with it.

The Plan! User Interface
The Elluminate Plan! interface consists of the Plan editor, the Quiz editor and the Whiteboard
editor. Normally, you will see the Plan editor only; however, you can make the Quiz and White-
board editors visible using the optional Tab bar (which, by default, is hidden). The interface also
includes the standard Title and Menu bars.

Moving Between Editors
The Plan editor is displayed when you open Elluminate Plan! To switch to the Quiz or White-
board editor, select it from the View menu. The View menu also gives you the option to show
the Tab bar which lets you quickly move between editors.
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The Plan Editor
The Plan editor consists of four elements:

l The Tool bar contains buttons to perform common operations.

l The Embedded Files list contains the embedded content of the session plan.

l The Plan Outline contains the individual items that constitute the session plan.

l The Properties panel contains session plan, file or item options, depending on which is
currently selected.1

Note:When you run the session plan in Blackboard Collaborate, of the
above elements, only the Plan Outline and Embedded Files list will be dis-
played. By default, the Embedded Files list is collapsed (hidden) so you
will have to pull down the divider to display the list.

1The Properties panel displays item properties if an item is selected in the Plan Outline. It dis-
plays file properties if a file is selected in the Embedded Files list. If no item or file is selected, it
displays session plan properties.
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The Plan Editor Tool Bar

The command buttons in the Plan editor Tool bar are grouped according to function:

The Embedded Files List

The Embedded Files list is a scrollable list of the files you have added to the session plan as
embedded content.

The Plan Outline

The individual items within your Plan Outline can be easily identified. By default, Topics and
Text Items are formatted (bold and italic, respectively) and Actions have distinct icons.

Tip: For details on customizing the appearance of the Plan Outline, see
Setting Session Plan Properties on page 45 and Setting Elluminate Plan!
Preferences on page 49.
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The Whiteboard Editor
Often a whiteboard file will be the core content in your session plan. You can load an existing
whiteboard file created in Blackboard Collaborate or create a new one in the Whiteboard editor
of Elluminate Plan! and then load it into the session plan. This window provides the full func-
tionality of the Blackboard Collaborate whiteboard within Elluminate Plan! (For details, see Cre-
ating a Whiteboard File on page 53.)
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Tip: See the chapter entitled The Whiteboard in theModerator’s Guide
for full instructions on using the Whiteboard features.

Note: Custom clip art libraries created in Elluminate Plan!will not be
added to Blackboard Collaborate when you load the session plan. You
must add custom clip art collections directly in Blackboard Collaborate.
Information on custom clip art collections can be found in the chapter
entitled The Whiteboard in theModerator’s Guide.

The Quiz Editor
If you wish to include a Quiz in your session plan, you can load an existing quiz file created in
Blackboard Collaborate or create a new one in the Quiz editor of Elluminate Plan! and then load
it into the session plan. The Quiz editor provides the full functionality of the Quiz Manager
within Blackboard Collaborate. (For details, see Creating a Quiz File on page 55.)

Tip: See the chapter entitled The Quiz Manager in theModerator’s Guide for full
instructions on using the Quiz Manager features.
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Launching and Exiting Elluminate Plan! 

Pre-Launch Configuration: Setting Your Language
Elluminate Plan! can be displayed in English, Spanish, French and Portuguese (Brazilian).
Ensure that the locale of your operating system is set to the appropriate language/location for
the desired language of Elluminate Plan! before launching the application.

Note: If you set your language to something other than one of the four
supported languages, Elluminate Plan! will be presented to you in English.

Instructions for changing the locale on Windows can be found under Enabling the translation
for your computer in the following Knowledge Base Article:

http://support.blackboardcollaborate.com/ics/support/default.asp?

deptID=8336&task=knowledge&questionID=1836

Note: Training, documentation and support are available in English only.

Launching Elluminate Plan!
To launch Elluminate Plan!, do one of the following:

o Click or double-click on the Elluminate Plan! application icon (depending on the icon loca-
tion and the operating system being used).

o (Windows only) Select Start menu > Programs > Elluminate > Elluminate Plan! > Ellu-
minate Plan! (if you used the default installation location).

o (SUSE Linux only) Select Application Launcher > Applications > Elluminate Plan (if you
used the default installation location).

o (Ubuntu Linux only) Select Application > Other > Elluminate Plan (if you used the default
installation location).

o (Solaris only) Select Launch > Application > Office > Elluminate Plan (if you used the
default installation location).

A new, empty plan will open automatically, ready for you to edit.

Being a document-based application, Elluminate Plan! also can be launched by opening an exist-
ing session plan (.elp or .elpx) file. For details, see Opening an Existing Session Plan on page 16.
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Automatic Check For Updates

Elluminate Plan!, by default, will automatically check for software updates. If a new version of
the software is available, you will be notified of the update.

When presented with the New Update Available dialog, you have three options:

o Click on Go to Web Site: this will take you to the Elluminate Plan! product download
web page (http://www.elluminate.com/Other/Download_Plan!_V2/?id=150) where you
can download the latest version of Elluminate Plan! for your specific platform.

Tip: See the Elluminate Plan! Installation and Registration Guide
for instructions on installing and registering Elluminate Plan!

o Click on Remind Later: this will skip the update for now and will cause this update noti-
fication to be displayed again next time you launch Elluminate Plan!

o Click on Ignore Update: this will prevent Elluminate Plan! from checking for updates
next time you launch the application. For example, if you have version 2.0 and click on
Ignore Update when notified that version 2.1 is available, you will not be reminded
again to update to version 2.1. (However, when version 2.2 becomes available, youwill be
notified since Ignore Update is ignoring version 2.1 only.)

Tip: If you accidentally clicked on Ignore Update, you can always
manually check for updates by selecting Help > Check for Update. If
there is an update available, you can go to the website to download
it or click on Remind Later to be reminded next time you launch
Elluminate Plan!

If you prefer not to be notified of software updates, you can turn off the option Check for
updates automatically at launch in the Preferences dialog. (For details on changing preferences,
see Setting Elluminate Plan! Preferences on page 49.)

Tip:We recommend that you leave the option Check for updates
automatically at launch selected – then you will always know when a
software update is available.
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Exiting Elluminate Plan!
To exit Elluminate Plan!, you can either perform an Exit or Quit operation or Close the window:

Note: If you exit/quit the application or close the application window
without first saving your session plan, you will be prompted to save your
changes. For details, refer to Saving a Session Plan on page 17.

Exit or Quit Operation

To exit (Windows) or quit (Linux, Solaris and Mac) Elluminate Plan!, do one of the following:

o (Windows) Select File > Exit.
o (Linux and Solaris) Select File > Quit.
o (Mac) Select Elluminate Plan! > Quit.
o (Linux) Press Ctrl+Q.
o (Mac) Press ⌘Q.

Close Window Operation

To close Elluminate Plan!, do one of the following:

o Select File > Close Window.
o Click on the Close Window button in the title bar of the Elluminate Plan! window.
o Press Ctrl+W (⌘W on Mac).
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Working with Session Plan (.elpx) Files

Creating a New Session Plan
When you launch Elluminate Plan! using the application icon,1 you will be presented with a
new, empty session plan – you don’t have to explicitly create a new session plan. However, if you
already have a session plan open in Elluminate Plan!, you can create another new plan by doing
one of the following:

o Select File > New.
o Press Ctrl+N (⌘N on Mac).
o Click on the Create New button in the Tool bar.

Opening an Existing Session Plan
To open an existing session plan (.elpx file or an Elluminate Plan! 1.0 .elp file) from within Ellu-
minate Plan!, select it from your file browser’s Open dialog by do one of the following:

o Select File > Open.
o Press Ctrl+O (⌘O on Mac).
o Click on the Open button in the Tool bar.

To open an existing session plan (.elpx) file from outside of Elluminate Plan!, do one of the fol-
lowing:

o Double-click on an .elp or .elpx file.
o Double-click on a Whiteboard (.wbd or .wbp) file or a Quiz (.vcq) file in your file browser.
Elluminate Plan! will show either the Whiteboard Editor or Quiz Editor, not the Plan
Editor.

o Right-click (or Ctrl-Click on Mac) on an .elpx file and select Open from the context
menu.

o Drag an .elpx file onto the Elluminate Plan! icon.

1as opposed to launching it by opening an .elp or .elpx file
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Note: The progress within a session plan is persistent across sessions: ses-
sion plans that already have been used to conduct a Blackboard Col-
laborate session will display markers that show what items have been
covered (completion indicators) and a progress marker to indicate where
the presenter left off in the presentation (the current item). (For details,
see Tracking Your Progress on page 70.)

Printing a Session Plan
When you print a session plan (.elpx) file, the contents of the Plan Outline are printed – just as
they appear in the Plan Outline. To print a session plan, do one of the following:

o Select File > Print.
o Press Ctrl+P (⌘P on Mac).
o Click on the Print button in the Tool bar.

Tip: If required, first specify your page setup options in the Page Setup
dialog (File > Page Setup).

Saving a Session Plan
When you save a session plan (.elpx) file, the contents of the Plan Outline and all embedded files
are saved, along with all session plan properties and preference settings. To save a session plan
(.elpx) file, do one of the following:

o Select File > Save.
o Press Ctrl+S (⌘S on Mac).
o Click on the Save button in the Tool bar.

The first time you save a session plan, Elluminate Plan! presents you with the Save Session Plan
dialog so you can enter the name of the file and choose a location where you would the file to be
saved.

To save a session plan (.elpx) to a different file name, do one of the following:

o Select File > Save As.
o Press Ctrl+Shift+S (⇧⌘S on Mac).

Note: If the session plan you were editing was an Elluminate Plan! 1.0
(.elp) file, it can be saved only as an Elluminate Plan! 2.0/2.1 (.elpx) file.
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Creating a Session Plan
There is no set strategy for creating a session plan but, ultimately, you need to embed content
files into the session plan and then create Actions, Topics, Text Items and notes around that con-
tent.

Tip: If the primary content in your Blackboard Collaborate session will be
whiteboard screens, a good way to begin your session plan is to first
embed your whiteboard file. If you won’t be using whiteboard screens, you
may want to begin your session plan by embedding other content or
creating an outline of Topics and subtopics.

As you create your content, Elluminate Plan! constantly validates your changes while you work
to ensure you have entered Actions in a logical fashion, that required properties have been
entered (and are valid) and that embedded files have been loaded. For details, see Validating
Your Session Plan on page 48.

Adding Content Files
To use pre-existing content (whiteboard, multimedia, quiz or other files) in your session plan,
you must do, at minimum, the first step listed below (the other two steps are optional):

1. Embed the content file into Elluminate Plan! There are two ways to add content files to a
session plan:

o Add the file directly to the Embedded Files list: when you add the file this way, you
will need to manually create any desired file-related Actions for that file in the Plan
Outline (see step 3 below).

o Add the file to the Plan Outline: when you add the file this way, you automatically
will be creating a file-related Action in the Plan Outline (and can skip step 3 below)
and also will be adding the file to the Embedded Files list.

Note: An embedded file cannot directly be shared via Application
Sharing – files must reside on your desktop in order to be shared.
For details, see A Note on Embedding Files to be used for Appli-
cation Sharing on page 28.
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2. (Optional) In most cases, the default values for file properties should be sufficient. If not,
in the Properties panel, you can specify whether or not you would like the file loaded into
the Blackboard Collaborate session automatically when the session plan is first activated in
the session and, if so, how you would like Blackboard Collaborate to treat the file (e.g., as a
file for transfer, as a multimedia file for playing, as a whiteboard or as a quiz). For white-
board files, you also may specify where1 you want Blackboard Collaborate to load the
whiteboard screens.

3. (Optional) Add file-related Actions to the Plan Outline, specifying when and how you want
Blackboard Collaborate to use the embedded content.

Note: If you embedded the file into the session plan by dragging and drop-
ping it into the Plan Outline you will already have an Action associated
with the embedded file.

Adding a Whiteboard File

Often, a whiteboard file will be the core content in your session plan. You can add an existing
whiteboard file created in Blackboard Collaborate or create a new one in the Whiteboard editor
of Elluminate Plan! (see Creating a Whiteboard File on page 53) and then load it into the ses-
sion plan.

Step 1: Embed the file.

To add a whiteboard file to your session plan, select a whiteboard (.wbd or .wbp) file by doing
one of the following:

o Select Plan > Add File.
o Press Ctrl+F (⌘F on Mac).
o Click on the Embed File button in the Tool bar.

o Right-click (Ctrl-Click on Mac) on the Embedded Files list and select Add File… from the
context menu.

o Drag and drop a whiteboard file from your file browser, another session plan’s Embedded
Files list or another application (e.g., your email application) into the Embedded Files list.

o Drag and drop a whiteboard file from your file browser, another session plan’s Embedded
Files list or another application (e.g., your email application) into the Plan Outline (thus
creating a file-related Action for each whiteboard screen). The file will also be added to the
Embedded Files list.

1In relation to any pre-existing whiteboard screens in the session. If you do not specify a target,
the current whiteboard screen will be replaced.
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The Properties panel will display Embedded Files-related fields and functions.

Note: You also can load PowerPoint or Ope-
nOffice.org presentations, PDF files or image files as
whiteboard (.wbd) files. For details, see Creating
Whiteboard Screens from Image, PDF and Pre-
sentation Files on page 53.

If you embedded the whiteboard file by dragging and dropping it in the Plan Outline, a Topic
automatically will be created corresponding to the name of the whiteboard file and Change
Whiteboard Screen Actions1 will be created for every screen in the whiteboard.

Note: Each of the Change Whiteboard Screen Actions will have the
description
Go to Screen “[screen name]”.

Tip: If the whiteboard file you are embedding contains some identically
named screens, be sure to edit the Change Whiteboard Screen Actions so
they are uniquely named. If they are identical, only the first Action will
navigate to the correct screen.
Better yet, make sure the screens in your whiteboard file are uniquely
named prior to embedding the whiteboard into your session plan.

1For further details on this Action, see Change Whiteboard Screen Action on page 40.
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Step 2: Specify the file properties.

The whiteboard file properties are used to specify whether or not you would like the whiteboard
screens loaded automatically when the session plan is first activated in the Blackboard Col-
laborate session and, if so, where those screens should be placed.

Note: There already may be whiteboard screens
loaded in a session prior to the session plan being
opened. If you are loading additional whiteboard
screens via the session plan, you can specify where
you want them placed in relation to the existing
screens. They will be added when the session plan is
activated.

Name: This is a read-only field containing the name of your embedded whiteboard file.

Load Automatically: By default, this option is turned on. It will load the file automatically
when the session plan is first activated in the Blackboard Collaborate session. (A green dot in the
Embedded Files list indicates this option is turned on for this file.) If the option is turned off, in
order for the presenter to load the file manually during the Elluminate Live session, you need to
add a Load File into Whiteboard Action to your session plan. The presenter can simply select
the Action during the session to load the whiteboard screens.
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Command: By default, set to Load File into Whiteboard.

n Load File for Transfer – if selected, when the session plan is first activated in the Black-
board Collaborate session, the whiteboard file will be loaded into your file transfer library,
ready for sharing with session attendees. The screens will not be loaded into Blackboard
Collaborate’s whiteboard.

n Prompt Participants – if selected, when you carry out a file transfer, session attendees will
be asked if they would like to receive the file transfer.

Tip: If you de-select Prompt Participants, you can still prompt
participants to save the file for transfer later on by inserting the
Prompt to Save File Action.

n Load File into Whiteboard – if selected, when the session plan is first activated in the
Blackboard Collaborate session, all the whiteboard screens will be loaded into the session.
This command has the following options:

Select one of the following Operation options to specify where you would like the new
whiteboard screens placed. The default is Insert At End.

n Replace All Screens – select this option to have the screens in this whiteboard file
replace all screens currently loaded in the whiteboard.

n Insert After Screen – select this option to insert the screens in this whiteboard file
after the current screen of the currently loaded whiteboard file.

n Insert At End – select this option to have the screens in this whiteboard file be
inserted after the last screen of the currently loaded whiteboard file.

Note: Regardless of which Operation you select, if there are no white-
board screens currently loaded into the session, the loaded whiteboard
will replace the default blank screen in the Blackboard Collaborate session
(Public Screen 1).

Step 3: Add related Actions.

If you added the whiteboard file via the Embedded Files list (rather than directly into the Plan
Outline), there will be no whiteboard file-related Actions in the Plan Outline. If you would like
to create a Change Whiteboard Screen Action (called Go to Screen) for each screen in the white-
board file, copy and paste or drag and drop the file from the Embedded Files list into the Plan
Outline. In addition to the Change Whiteboard Screen (Go to Screen) Actions, a Topic (of the
same name as the whiteboard file) automatically will be added above the first Change White-
board Screen Action.
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Tip: If the whiteboard file you are embedding contains some identically
named screens, be sure to edit the Change Whiteboard Screen Actions so
they are uniquely named. If they are identical, only the first Action will
navigate to the correct screen. Better yet, make sure the screens in your
whiteboard file are uniquely named prior to embedding the whiteboard
into your session plan.

When you run the session plan in Blackboard Collaborate and select a Go to Screen Action, you
automatically will go to the specified screen.

Adding a Quiz

You can add an existing quiz created in Blackboard Collaborate or create a new one in the Quiz
editor of Elluminate Plan! (see Creating a Quiz File on page 55) and then embed it into the ses-
sion plan.

Step 1: Embed the file.

To add a quiz to your session plan, select a quiz (.vcq) file by doing one of the following:

o Select Plan > Add File.
o Press Ctrl+F (⌘F on Mac).
o Click on the Embedd File button in the Tool bar.

o Right-click (Ctrl-Click on Mac) on the Embedded Files list and select Add File… from the
context menu.

o Drag and drop a quiz file from your file browser, another session plan’s Embedded Files
list or another application (e.g., your email application) into the Embedded Files list.

o Drag and drop a quiz file from your file browser, another session plan’s Embedded Files
list or another application (e.g., your email application) into the Plan Outline (thus cre-
ating a file-related Action). The file will also be added to the Embedded Files list.

The Properties panel will display Embedded Files-related fields and functions.

23Using the Session Plan Editor



Step 2: Specify the file properties.

Name: This is a read-only field containing the name of your embedded quiz file.

Load Automatically: By default, this option is turned on. It will load the file automatically
when the session plan is first activated in the Blackboard Collaborate session. (A green dot in the
Embedded Files list indicates this option is turned on for this file.) If the option is turned off, in
order for the presenter to load the file manually during the Blackboard Collaborate session, you
need to add a Load Quiz Action to your session plan. The presenter can simply select the Action
during the session to load the quiz.

Command: By default, set to Load Quiz.

n Load Quiz – if selected, when the session plan is first activated in the Blackboard Col-
laborate session, the quiz file will be loaded into your quiz library.

n Load File for Transfer – if selected, when the session plan is first activated in the Black-
board Collaborate session, the quiz file will be loaded into your file transfer library, ready
for sharing with session attendees.

l Prompt Participants – if selected, when you carry out a file transfer, session attend-
ees will be asked if they would like to receive the file transfer.

Tip: If you de-select Prompt Participants, you can still
prompt participants to save the file for transfer later on by
inserting the Prompt to Save File Action.

n None – this is automatically selected when the option Load Automatically is turned off.

Step 3: Add related Actions.

To use the quiz file in the Blackboard Collaborate session, add quiz-related Actions (Load Quiz,
Start Quiz and Stop Quiz) or a file transfer Action (Load File for Transfer) to the Plan Outline.
(For details, see Creating Actions for Embedded Files on page 35 .) If you added the quiz file to
the session plan by copying and pasting or dragging and dropping the quiz file directly into the
Plan Outline, Start Quiz and Stop Quiz Actions automatically will be added to the Plan Outline.
Add additional Actions as desired.

Note: Because a quiz (.vcq) file can contain more than one quiz, when
defining a Start Quiz Action, be sure to enter the name of the desired quiz
in the Quiz Name field.
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Adding Multimedia

Step 1: Embed the file.

To add a multimedia file to your session plan, select a multimedia file (WMV, MPEG, MP3,
QuickTime or Flash file) by doing one of the following:

o Select Plan > Add File.
o Press Ctrl+F (⌘F on Mac).
o Click on the Embed File button in the Tool bar.

o Right-click (Ctrl-Click on Mac) on the Embedded Files list and select Add File… from the
context menu.

o Drag and drop a multimedia file from your file browser, another session plan’s Embedded
Files list or another application (e.g., your email application) into the Embedded Files list.

o Drag and drop a multimedia file from your file browser, another session plan’s Embedded
Files list or another application (e.g., your email application) into the Plan Outline (thus
creating a file-related Action). The file will also be added to the Embedded Files list.

The Properties panel will display Embedded Files-related fields and functions.

Step 2: Specify the file properties.

Name: This is a read-only field containing the name of your embedded multimedia file.

Load Automatically: By default, this option is turned on. It will load the file automatically
when the session plan is first activated in the Blackboard Collaborate session. (A green dot in the
Embedded Files list indicates this option is turned on for this file.) If the option is turned off, in
order for the presenter to load the file manually during the Elluminate Live session, you need to
add a Load Multimedia Action to your session plan. The presenter can simply select the Action
during the session to load the multimedia file.

Command: By default, set to Load Multimedia.

n Load Multimedia – if selected, when the session plan is first activated in the Blackboard
Collaborate session, the multimedia file will be loaded into your multimedia library.
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n Load File for Transfer – if selected, when the session plan is first activated in the Black-
board Collaborate session, the multimedia file will be loaded into your file transfer library,
ready for sharing with session attendees.

n Prompt Participants – if selected, when you carry out a file transfer, session attendees will
be asked if they would like to receive the file transfer.

Tip: If you de-select Prompt Participants, you can still prompt
participants to save the file for transfer later on by inserting the
Prompt to Save File Action.

n None –this is automatically selected when the option Load Automatically is turned off.

Step 3: Add related Actions.

To use the multimedia file in the Blackboard Collaborate session, add a multimedia-related
Actions (Load Multimedia, Play Multimedia and Stop Multimedia) or a file transfer Action
(Load File for Transfer) to the Plan Outline. (For details, see Creating Actions for Embedded
Files on page 35.) If you added the multimedia file to the session plan by copying and pasting or
dragging and dropping the multimedia file directly into the Plan Outline, a Play Multimedia
Action automatically will be added to the Plan Outline. Add additional Actions as desired.

Adding Other Files

Any type of file can be embedded into a plan for the purposes of file sharing in Blackboard Col-
laborate.

Step 1: Embed the file.

To add any file to your session plan, select the file by doing one of the following:

o Select Plan > Add File.
o Press Ctrl+F (⌘F on Mac).
o Click on the Embed File button in the Tool bar.

o Right-click (Ctrl-Click on Mac) on the Embedded Files list and select Add File… from the
context menu.

o Drag and drop a file from your file browser, another session plan’s Embedded Files list or
another application (e.g., your email application) into the Embedded Files list.

o Drag and drop a file from your file browser, another session plan’s Embedded Files list or
another application (e.g., your email application) into the Plan Outline (thus creating a
Load File for Transfer Action). The file also will be added to the Embedded Files list.
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The Properties panel will display Embedded Files-related fields and functions.

Step 2: Specify the file properties.

Name: This is a read-only field containing the name of your embedded file.

Load Automatically: By default, this option is turned on. It will load the file automatically
when the session plan is first activated in the Blackboard Collaborate session. (A green dot in the
Embedded Files list indicates this option is turned on for this file.) If the option is turned off, in
order for the presenter to load the file manually during the Elluminate Live session, you need to
add a Load File for Transfer Action to your session plan. The presenter can simply select the
Action during the session to load the file.

Command: By default, set to Load File for Transfer.

n Load File for Transfer – if selected, when the session plan is first activated in the Black-
board Collaborate session, the file will be loaded into your file transfer library, ready for
sharing with session attendees.

l Prompt Participants – if selected, when you carry out a file transfer, session attend-
ees will be asked if they would like to receive the file transfer.

Tip: If you de-select Prompt Participants, you can still
prompt participants to save the file for transfer later on by
inserting the Prompt to Save File Action.

n None – this is automatically selected when the option Load Automatically is turned off.

Step 3: Add related Actions.

If the file is not set to load automatically in the Blackboard Collaborate session, add a file trans-
fer Action (Load File for Transfer) to the Plan Outline. (For details, see Creating Actions for
Embedded Files on page 35.) If you added the file to be transferred to the session plan by drag-
ging and dropping the file directly into the Plan Outline, a Prompt to Save File Action auto-
matically will be added to the Plan Outline and you will not have to create any more Actions.
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A Note on Embedding Files to be used for Application Sharing

An embedded file cannot be application shared directly. However, as a content pro-
vider, you may want your session plan to contain everything related to the session so
that all session-related material can be delivered to session presenters. If this is the
case, you might want to embed a file you intend to be shared via Application Sharing.
You will need to instruct your presenters to do the following in the Session Plan win-
dow in the Blackboard Collaborate session:

1. Open the Embedded Files list by dragging the divider down. (See Viewing the
Embedded Files List on page 60.)

2. Copy and paste or drag and drop the files to be application shared from the
Embedded Files list to their desktops (or anywhere accessible to their file
browser, such as a network server).

Adding Topics
Topics provide structure and context to your session plan. A topic has a name and, optionally,
can contain presenter notes and a suggested duration. Topics can contain other session plan
items: other Topics (subtopics), Actions and Text Items.

Note: For a discussion of the placement of new items in a session plan,
refer to Appendix B, “Rules for Inserting and Indenting Session Plan
Items”.

To create a Topic, do the following:

1. Select the item in the Plan Outline after which you would like to insert a new Topic.

Note: If you do not select an existing item, the new Topic will be
appended to the end of the session plan.
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2. Add a Topic by doing one of the following:
o Select Plan > Add Topic.
o Press Ctrl+T (⌘T on Mac).
o Click on the Add Topic button in the Tool bar.

o Right-click (Ctrl-Click on Mac) on the selected item and select Add Topic from the
context menu.

o Copy an existing Topic using Ctrl+C (⌘C on Mac) and paste it to the new location
using Ctrl+V (⌘V on Mac).

Tip: This is useful when you want to insert a Topic with the same
properties as an exiting Topic. This will save you time as properties
are copied along with the Topic and there will be no need to enter
them again.

The Properties panel will display Topic-related fields and functions.

3. (Optional) Type presenter notes for the Topic.

Note: Presenter notes are not displayed in the outline of the ses-
sion plan. They are shown in the bottom of the session plan while it
is running in Blackboard Collaborate and appear to Moderators
only.

4. (Optional) Set a suggested duration for the Topic. This is just a suggested time that pre-
senters can use to pace themselves – nothing will occur when the duration timer has run
its course.

You can create any number of topics and organize them as subtopics. There are two ways to do
this:

o Select an existing topic and add a new topic. The new topic will be added as a subtopic of
the selected one. Whenever a topic is selected, any new item (Topic, Action or Text Item)
added to the outline will be inserted as a “child” of the topic.
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o Move an existing topic under another topic and indent it. (For details, seeMoving Items
and Embedded Files on page 43.)

Note: In Blackboard Collaborate, only one duration timer can run at a
time. If you move to a sub-item that also has a timer, the sub-item’s timer
will start running only if its parent's timer (or another sub-item's timer)
has stopped.

Adding Actions
Actions include a description and a command (with its parameters) that will be triggered in
Blackboard Collaborate. Optionally, an Action can contain presenter notes and a suggested dura-
tion.

Tip:Many Actions work in conjunction with others. When adding
Actions to your session plan, be sure to also include “prerequisite”
Actions. For example, you can’t stop an Application Sharing session unless
you have already started one and you can’t close a breakout room unless
one previously had been created. The validation system will assist you and
tell you when something is missing or out of order. (See Validating Your
Session Plan on page 48.)

Note: Actions also can be grouped together into Compound Actions. (For
details, see Creating Compound Actions on page 36.)

1. Add the Action to the Plan Outline using one of the following methods:

Note: For Actions operating on an embedded file, you can cir-
cumvent the Add Action dialog, Action Palette or Add Action menu
entirely. See Creating Actions for Embedded Files on page 35.

o Copy an existing Action using Ctrl+C (⌘C on Mac) and paste it to the new loca-
tion using Ctrl+V (⌘V on Mac).

: This is useful when you want to insert an Action with the
same properties as an existing Action. This will save you time
as the properties are copied along with the Action and there
will be no need to re-enter them.
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o Use the Add Action menu.

a. Select the Action in the Plan Outline after which you would like the new
Action placed.

Note: If you do not select an existing item, the new
Action will be appended to the bottom of the session
plan.

b. Click on the Add Action button to open the Add Action Menu and select

the desired Action.
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o Use the Add Action dialog. This dialog will close when you have added an
Action.

Tip: Use the disclosure buttons in the Add Action dialog to
reveal or hide Actions in the list.

a. Select the Action in the Plan Outline after which you would like the new
Action placed.

Note: If you do not select an existing item, the new
Action will be appended to the bottom of the session
plan.

b. Open the Add Action Dialog in one of the following ways:
o Select Plan > Add Action
o Enter Ctrl+G (⌘G on Mac)
o Select Add Action from the context menu
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c. Select the desired Action.

d. Click on the Add button or double-click on the desired Action.
o Use the Action Palette. This palette will stay open for the duration of your edit-
ing session or until you explicitly close it.

Tip: Use the disclosure buttons in the Action Palette to reveal
or hide Actions in the list.

a. Open the Action Palette in one of the following ways:
o Select Window > Actions – Action Palette
o Click on Add Action button and select Open Action Palette from

Add Action menu – Action Palette

b. Add the Action in one of the following ways:
o Drag and drop the desired Action to the desired location in the Plan
Outline.

o Select the Action in the Plan Outline beneath which you would like
your new Action placed. Double-click on the new Action in the palette.

The Properties panel will display Action-related fields and functions.
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2. (Optional) Modify the Description for the Action or keep the default description given.

Tip: Although you can keep the default
Description or leave the Description field
blank (the Action will execute just fine in
your Blackboard Collaborate session), you are
strongly encouraged to provide a meaningful
description for your Action. For example, a
description of “Play Lab Safety Video” is
considerably more informative to a presenter
(and anyone who can view the session plan)
than “Play Multimedia”.

3. (Optional) Change the Command, if desired. You can do so by selecting a different com-
mand from the Command dropdown menu.

4. Set the Command parameters in the Properties panel.

Note:With a few noted exceptions (see Enhanced Actions on
page 37), the commands and parameters available in Elluminate
Plan! are identical to those within Blackboard Collaborate. Refer to
theModerator’s Guide for detailed instructions on setting com-
mand parameters.
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5. (Optional) Type presenter notes for the Action. Presenter notes are not displayed in the
outline of the session plan. They are shown in the bottom of the session plan while it is
running in Blackboard Collaborate and appear to Moderators only.

Note: Presenter notes cannot be added to sub-Actions of Com-
pound Actions. If you move an existing Action containing presenter
notes into a Compound Action, the notes will no longer be dis-
played.

Note: If your Whiteboard file is a converted PowerPoint or Ope-
nOffice.org presentation any presenter notes associated with the
presentation slides will be inserted automatically in the Presenter
Notes field of each applicable Change Whiteboard Screen action.
When the session plan is run in Blackboard Collaborate, these pre-
senter notes also will be copied into the Notes Editor of all session
attendees.

6. (Optional) Set a suggested duration for the Action. This is just a suggested time that pre-
senters can use to pace themselves – nothing will occur when the timer has run its course.

Note: Suggested durations cannot be added to sub-Actions of Com-
pound Actions. If you move an existing Action containing a sug-
gested duration into a Compound Action, the suggested duration
will no longer be displayed.

Creating Actions for Embedded Files

Generally speaking, you should embed all content to be presented in the session.

Note: An embedded file cannot directly be shared via Application Sharing
– files must reside on your desktop in order to be shared. For details, see
A Note on Embedding Files to be used for Application Sharing on
page 28.

For Actions operating on an embedded file, you can circumvent the Add Action dialog, Action
Palette or Add Action menu entirely by copying and pasting or dragging and dropping the embed-
ded file directly from the Embedded Files list or from you desktop to the Plan Outline. The fol-
lowing Actions will be automatically added to your plan outline, depending on the file type:1

1If the file is copied/pasted or dragged/dropped from your desktop into the Plan Outline, it will
be added to the Embedded Files list as well.
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n Whiteboard: Change Whiteboard Screen Action added for each slide in the file.1

n Quiz: Start Quiz and Stop Quiz for each quiz in the file.

n Multimedia: Play Multimedia.

n Other: Prompt to Save File.

You can change the default command to another command afterwards. For example, if, in your
Blackboard Collaborate session, you want to file transfer a multimedia file, copy and paste or
drag and drop the file from the Embedded Files list into the Plan Outline. By default, the Com-
mand will be Play Multimedia. You can then change the command to Load File for Transfer so
the file will be loaded into the file transfer library, not the multimedia library, in Blackboard Col-
laborate.

Creating Compound Actions

When creating Compound Actions, keep in mind that sub-Actions of a Compound Action are
executed together in a single step during the live session, so do not place two sub-Actions that
counteract each other (e.g., Share Desktop and Stop Sharing or Create Room and Close Room)
next to each other – they will cancel each other out.

Note: You may nest Compound Actions: insert Compound Actions as
sub-Actions of other Compound Actions. However, the result is the same
as if you had made all sub-Actions part of the same parent Action – every-
thing still will be executed at once in the order they are listed when you
run the plan.

To group Actions together into Compound Actions, do the following:

1. Select Compound Action from the Add Action menu, the Add Action dialog or the Action
Palette. For instructions, refer to Step 1 under Adding Actions on page 30.

The Properties panel will display Action-related fields and functions.

1For further details on this Action, Change Whiteboard Screen Action on page 40.
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2. Enter a meaningful Description for the Compound Action, preferably one that reflects
what Actions will be included in this Compound Action.

3. (Optional) Type presenter notes for the Compound Action. Presenter notes are not dis-
played in the outline of the session plan. They are shown in the bottom of the session plan
while it is running in Blackboard Collaborate and appear to Moderators only.

Tip: Presenter notes cannot be added to sub-Actions of Compound
Actions so, if you want to include notes about the sub-Actions, be
sure to include them in the presenter notes of the Compound
Action.

4. (Optional) Set a suggested duration for the Compound Action. This is just a suggested time
that presenters can use to pace themselves – nothing will occur when the duration timer
has run its course.

Tip: Specify a suggested duration that represents the aggregate time
it will take to complete all sub-Actions contained within this
Compound Action. Suggested durations cannot be set for sub-
Actions – only for their “parent” Compound Action.

5. Be sure the Compound Action is selected and then add the Actions to be inserted as sub-
Actions of the Compound Action. The sub-Actions will automatically be indented under
the Compound Action and become part of it. (For details, see Adding Actions on page 30.)

Enhanced Actions

While the commands and their parameters in Elluminate Plan! are generally identical to the
ones found in Blackboard Collaborate, there are a few Actions that have extended functionality
not directly available in Blackboard Collaborate – although theywill trigger events in the Black-
board Collaborate session.
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Share Application Action

When starting application sharing in Blackboard Col-
laborate, you are presented with a dialog asking you what
currently running application you want to share.

When you run a session plan, however, you may not be
running the application to be shared. Therefore, when
you build the session plan, you need to tell Elluminate
Plan! the name of the application to be opened and
shared. You do so by typing or browsing to the name of
the application in the Application field.

If you don’t know the exact name of the application file, browse to the application
rather than typing in its name.

A Note on Finding Applications

When you click on the Browse button, Elluminate Plan! will open the default appli-
cation directory for your operating system:

Windows Mac Linux/Solaris

C:\Program Files\ /Applications/ /opt/

On Windows and Mac, Internet Explorer can be found in the Internet Explorer sub-
folder, Firefox can be found in the Mozilla Firefox subfolder and Microsoft Office appli-
cations can be found in the Microsoft Office subfolder. You may need to do a little digging
around in subfolders of the Microsoft Office directory to find your applications.

On the Mac, the applications are named exactly as you commonly refer to them (Word,
Excel, PowerPoint, etc.).
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In Windows, some of the applications are named as you commonly refer to them and
others are not:
       Excel: excel.exe PowerPoint: powerpnt.exe

       Publisher:mspub.exe Word: winword.exe

       Outlook: outlook.exe

If you don’t know the exact name of the application file or don’t know where the
application resides (e.g., it was not installed in the default location), please consult
your system administrator.

Linux and Solaris

When you run the session plan, Blackboard Collaborate will look to see if the application is
already running and, if so, will share it.1 If it cannot find the application amongst the running
applications, the Share Application dialog pops up, prompting you to select the application from
a list of running applications or browse to find an application not currently running.

Windows and Mac

When you run the session plan, Blackboard Collaborate will look to see if the application is
already running – if not, it will start it (something Blackboard Collaborate cannot do). For exam-
ple, if you are a Windows user who wants to share a Microsoft Word document, browse to or
type “winword” in the Application field. When your session plan is run in Blackboard Col-
laborate, Blackboard Collaborate will compare the application name with any applications cur-
rently running. If found, it will start sharing the application.

If the application is not running, Blackboard Collaborate will search for the application on disk.
If Blackboard Collaborate can’t find the application, it will ask the presenter to identify the appli-
cation. (The Application Sharing dialog will open, showing currently running applications. If the
application is not listed, the presenter can click on Browse to select the application.)

For example, Blackboard Collaborate running on a Mac will not find the application “winword”
since Microsoft Word is not called “winword” on the Mac (it is called “Microsoft Word”). The
Mac user will be prompted to select the application.

Note: An embedded file cannot directly be shared via Application Sharing
– files must reside on your desktop in order to be shared. For details, see
A Note on Embedding Files to be used for Application Sharing on
page 28.

1One exception is the Terminal application, which you will have to pick manually from the list of
running applications.
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Two small differences in Application Sharing command parameters also should be noted.

n Presenting: This is the same as the Blackboard Collaborate option Show in Presentation
mode – only the name is different. It will automatically open up your shared application in
Presentation Mode view.

n Exclude menu bar: This is the same as the Blackboard Collaborate Mac-only option
Exclude menu bar. In Elluminate Plan!the option is available on all platforms since the
session plan might end up being run on a Mac. Exclude menu bar will display the shared
application on a Mac without the screen menu bar. This is the default and is useful
because the screen menu bar always takes the entire width of the screen, which produces
a very large shared area.

Close All Rooms Action

If you want to close all breakout rooms in a Blackboard Collaborate session, you must first select
all the rooms and then select the Close Rooms command. Elluminate Plan! has a command to
do this all in a single step: Close all Rooms.

Send Chat Message

In Blackboard Collaborate, you can send a chat message to selected participants. This is not a via-
ble option in a session plan because you can’t know in advance who will be attending the ses-
sion. Therefore, the only options in the Recipients menu of the Send Chat Message Action are
All Rooms, This Room and Moderators.

Load File intoWhiteboard Action

Details of the unique functionality of this command in Elluminate Plan! are discussed in Adding
a Whiteboard File on page 19.

ChangeWhiteboard Screen Action

In Blackboard Collaborate, you visually indicate where to insert new screens in relation to the
existing screens. When navigating to screens via a session plan, you need to define the location
for the new screens using the Target Screen field and associated options.

n Target Screen – specify a screen already loaded into the whiteboard in the Blackboard Col-
laborate session. Click on the Browse button to open the Choose Screen dialog and
select the desired screen.

n Search From Screen Group – select if you want to search for the Target Screen in main,
top-level topics in addition to the current screen level.
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n Search Subtopics – select if you want to search for the Target Screen in subtopics of the
current screen level in addition to the current level. (This will search recursively through
all levels of subtopics of all screens at the current level, including subtopics of subtopics.)

Note: Select both Search From Screen Group and Search Sub-
topics if you want to search through all screens – starting at the
top-level screens, and looking recursively into all the topics and sub-
topics. Once the target screen is found at a certain level, the search
ends – the lower level topics or subtopics will not be searched.

Select neither Search From Screen Group nor Search Subtopics, if
you want to search through only the screens at the current topic
level (not in parent topics and not in subtopics).

Adding Text Items
A Text Item contains a simple text string. Optionally, it may contain a suggested duration. Long
Text Items will wrap in the Plan Outline.

1. Select the item in the Plan Outline after which you would like to insert a new Text Item.

Note: If you do not select an existing item, the new Text Item will
be appended to the bottom of the session plan.
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2. Add a Text Item by doing one of the following:
o Select Plan > Add Text Item.
o Press Ctrl+E (⌘E on Mac).
o Click on the Add Text Item button in the Tool bar.

o Right-click (Ctrl-Click on Mac) on the selected item and select Add Text Item from
the context menu.

o Copy an existing Text Item using Ctrl+C (⌘C on Mac) and paste it to the new loca-
tion using Ctrl+V (⌘V on Mac).

Tip: This is useful when you want to insert a Text Item with
the same properties as an exiting Text Item. This will save you
time as properties are copied along with the Text Item and
there will be no need to re-enter them.

The Properties panel will display Text Item-related fields and functions.

3. Type the desired text.

4. (Optional) Set a suggested duration for the Text Item. This is just a suggested time – noth-
ing will occur when the timer has run its course.

Working with Session Plan Items
When you have created the items in your plan, you may want to rename, reorder or remove
some of them. For embedded files, you can also edit the items or save them externally.

Items contained within a Topic or Compound Action (sub-items) can be moved or deleted
individually within a Topic or Compound Action. If the Topic or Compound Action is moved or
deleted, so will be its sub-items.

Tip: You can select multiple items and move or delete them all at once.
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Renaming Items

To change the name of an item in the Plan Outline, select the item and change the text in the
Properties panel: in the Name field for Topics, Description field for Actions and Text field for
text.

Note: Files in the Embedded Files list cannot be renamed.

Moving Items and Embedded Files

When you have created the items in your Plan Outline, you may want to reorder them (move
them up or down) or create a hierarchy of items by promoting and demoting items (moving
them left or right). To do so, do one of the following:

o Use the Move buttons in the Tool bar (as shown at the right).
o Use the Plan menu options: Move Up, Move Down, Move Left and
Move Right.

o Drag and drop items (to move up or down only)
o Cut the item using Ctrl+X (⌘X on Mac) and paste it to the new location
using Ctrl+V (⌘V on Mac).

o Use the keyboard shortcuts:
Ctrl+Up (⌘ on Mac)
Ctrl+Down (⌘ on Mac)
Ctrl+Left (⌘ on Mac)
Ctrl+Right (⌘ on Mac).

Note: For a discussion of the indentation of moved items in a session
plan, refer to Appendix B, “Rules for Inserting and Indenting Session
Plan Items”.

Removing Items and Embedded Files

Caution: This version of Elluminate Plan! does not have an undo
function. When you are prompted to confirm deletion, be certain to
respond appropriately.
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To remove a file from the Embedded Files list, select the file and do one of the following:

o Select Plan > Remove.
o Click on the Remove button in the Tool bar.

o Press the Delete or Backspace key.
o Right-click (Ctrl-Click on Mac) on the file to be removed and select Remove from the con-
text menu.

Note: If removing a file from the Embedded Files list, any Actions asso-
ciated with the file in the Plan Outline will not be deleted.

To remove an item from the Plan Outline, select the item and do one of the following:

o Select Plan > Remove.
o Click on the Remove button in the Tool bar.

o Press Ctrl+X (⌘X on Mac).
o Press the Delete or Backspace key.
o Right-click (Ctrl-Click on Mac) on the item to be removed and select Remove from the
context menu.

Caution: If you delete a Topic or Compound Action containing sub-
items, all the sub-items will be deleted as well.

Editing Embedded Files

Files in the Embedded Files list can be opened for editing.

1. To open an embedded file for editing, do one of the following:
o Double-click on the desired file in the Embedded Files list.
o Right-click (Ctrl-Click on Mac) on the desired file in the Embedded Files list and
select Edit from the context menu.
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2. Different file types are treated differently:

n Quiz files will be opened in the Quiz Editor. Edit the file and save it. Do not
change the file name or save into a different directory – you must over-
write the existing file! (For details on the Quiz Editor, see The Quiz Editor on
page 12.)

n Whiteboard Files will be opened in the Whiteboard Editor. Edit the file and save it.
Do not change the file name or save into a different directory – you
must overwrite the existing file! (For details on the Whiteboard Editor, see
The Whiteboard Editor on page 11.)

n Other files will be opened in the application set as the default for that file type on
your operating system. If there is no default application, most operating systems will
prompt you to browse to the appropriate application.

3. Finally, in order for the changes to the embedded files to be picked up by the session plan,
you must save the session plan. For details, see Saving a Session Plan on page 17.

Saving Embedded Files Externally

Files in the Embedded Files list can be saved externally to your desktop or network.

1. Selecting one or more the files to be saved.

2. Do one of the following:
o Select Plan > Save Embedded File.
o Click on the Save Embedded File button in the Tool bar.

o Right-click (Ctrl-Click on Mac) on the file to be saved and select Save from the con-
text menu.

o Copy and paste the file.
o Drag and drop the file.

3. In the Save dialog, select the folder in which you would like the file(s) saved.

Setting Session Plan Properties
There are three session plan properties that can be customized either in the Properties panel or
by selecting them from the Plan menu. These properties determine the look and behavior of the
session plan within Blackboard Collaborate and, if desired, can be overridden by a session plan
presenter (Moderator) during the Blackboard Collaborate session.
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Tip: If you don’t see the session
plan properties in the Properties
panel, this means you have a file
selected in the Embedded Files list
or an item selected in the Plan
Outline. Deselect the file or item or
select multiple files or items.

Duration Timers – Start Automatically: Controls whether or not the duration timer will
start automatically for items that have suggested durations. If the option Start Automatically is
not selected, timers will still be visible to session Moderators who can start them manually by
clicking on the timer bubble. (By default, this option is turned off.)

Note: To start duration timers automatically using a menu option, select
Plan > Start Timers Automatically. To turn this option off, deselect the
menu option.

Decorations – Show Action Icons: Specifies whether or not Actions in the session plan
should be displayed with their associated icons. (By default, this option is turned on.)

When Show Action Icons is on, you will see the following:
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When Show Action Icons is off, you will see the following:

Note: To show Action icons using a menu option, select Plan > Show
Action Icons. To turn this option off, deselect the menu option.

Labels: Determines the type of label that will be displayed next to items in the session plan.
(The default is None.)

For example, when Leader is selected, you will see the following:

And when 1.2.3 Legal is selected, you will see the following:
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Note: To specify item labels using a menu option, select the desired label
from the Plan > Labels submenu. To turn labels off, select None.

Note: Labels will be truncated if they become too long, exceeding the
space allotted for labels. For example, if you are using the Number label
and have more than 99 items at the first level, any items higher than 99
will be labeled with ellipses (...). The space limit for labels increases the
deeper an item is indented.

Validating Your Session Plan
As you create your content, Elluminate Plan! provides immediate feedback to ensure your ses-
sion plan does not contain any issues that may cause problems when the session plan is run in a
Blackboard Collaboratesession. The Elluminate Plan! validation system provides the following
checks:

n Checks that required properties are entered for Actions (e.g., message text is required for a
Send Chat Message Action) and checks that properties are valid (e.g., a Play Multimedia
Action references a multimedia file that has been embedded in the session plan).

n Checks that Actions are added in a logical fashion:

l Checks dependencies between Actions, where “prerequisite” Actions (e.g., Start
Recording) are inserted before dependent Actions (e.g., Pause Recording).

l Checks that an Action doesn’t block the next Action (e.g., can’t have Share Desktop
and Share Application adjacent to each other since Share Desktop disables Share
Application – a Stop Sharing Action is required between the two).

n Checks that embedded files are loaded into the session either explicitly or automatically (as
in the example screen capture below).

n Checks that the sum size of the embedded files does not exceed the allowed quota.
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If errors are found, they are highlighted in red (default color1) and an explanation of the prob-
lem and recommended solution displayed at the bottom of the Elluminate Plan! window when
the item is selected. (The explanation and recommendation are also displayed as tool tips.)

Setting Elluminate Plan! Preferences
Elluminate Plan! preferences are application settings that affect the look and behavior of Ellu-
minate Plan! – they are not associated with a specific session plan. Preferences are your per-
sonal settings2 for how you want Elluminate Plan! to look and behave.

You can open the Preferences dialog in one of the following ways, depending on your operating
system:

n (Windows, Linux and Solaris) From the Edit menu, select Preferences.

n (Mac) From the Elluminate Plan! menu, select Preferences.

The Preferences dialog is organized into two main areas: the Preferences list on the left and the
Preferences panels on the right. The Preferences list contains a list of modules and their asso-
ciated panels organized into a tree structure (in alphabetical order). The panel that is selected in
the Preferences list will be displayed in the Preferences panel area.

1To change the default color, see the Color of problem items option under Editing Options on
page 51.
2When someone else opens your session plan in Elluminate Plan!, they will see the session plan
with the fonts, etc. they have set up under their own Preferences.
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Tip: For a detailed discussion of the Preferences dialog, see the chapter
entitled Getting Started in theModerator’s Guide.

Application Preferences
General: Used to set the preference that manages the “check for updates” function.

n Check for updates automatically at launch: Used to specify whether or not to auto-
matically check the Elluminate website for a new version of Elluminate Plan! If the
option is selected, and there is a new version available, you will have the option to be redi-
rected to the Elluminate website to download the latest version. (By default, this option is
turned on.)
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Tip:We recommend that you leave the option to Check for updates
automatically at launch selected – then you will always know when a
software update is available.

Session Plan Preferences

Display Settings

Used to specify the appearance of items in the Plan Outline. The default values for font name
and size are based on the system settings for your specific platform.

One thing consistent across all platforms is that the Topic Font is bold and the Text Item font is
italics.

l Topic Font: Used to set the appearance of Topic items.

l Action Font: Used to set the appearance of Action items.

l Text Item Font: Used to set the appearance of Text Items.

Editing Options

Except for the Color of problem items preference, this panel is used to set default quota and
property values for the version of Blackboard Collaborate that will be used to run the session
plan. For example, if, in the future, Blackboard Collaborate is changed to accept 20 MB for file
transfers instead of 10, or is changed to accept 8 maximum talkers instead of 6, then you can use
this preference dialog to modify Elluminate Plan! to match the new values in Blackboard Col-
laborate. This means you will not necessarily have to upgrade your version of Elluminate Plan!

Caution: Do not change the quotas or action property values unless
instructed to do so by your system administrator or by a Technical
Notification from Elluminate.
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n Color of problem items: Sets the color of the highlighting used to display errors. The
default color is red. To change the default, click on the red square to open a color selector
dialog and select a different color. (For details on error checking, see Validating Your Ses-
sion Plan on page 48.)

Whiteboard Preferences
OpenOffice.org/StarOffice Installation: For details, refer to “Locating an OpenOffice
Installation” in theModerator’s Guide.
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Creating Content within Elluminate Plan!

Creating a Whiteboard File
To create a whiteboard file from within Elluminate Plan!, do the following:

1. Open the Whiteboard editor by doing one of the following:
o Select View > Whiteboard.
o Press Ctrl+3 (⌘3 on Mac).
o If the Tab bar is visible, click on the Whiteboard tab.

2. Load or create whiteboard screens exactly as you would from within Blackboard Col-
laborate.

Tip: See the chapter entitled The Whiteboard in theModerator’s
Guide for instructions on creating a whiteboard file.

3. Save your whiteboard file by doing one of the following:
o Select File > Save.
o Press Ctrl+3 (⌘3 on Mac).

Caution: Saving the session plan file when in the Plan editor will not
save the whiteboard file you just created – you must explicitly save the
whiteboard file from within the Whiteboard editor.

You now can add the file you just created to the session plan. (For details, see Adding a White-
board File on page 19.)

Creating Whiteboard Screens from Image, PDF and Presentation Files

Note:When a PowerPoint or OpenOffice.org presentation is being con-
verted to a Whiteboard file, any presenter notes associated with its slides
will be inserted automatically in the Presenter Notes field of each appli-
cable Change Whiteboard Screen action. When the session plan is run in
Blackboard Collaborate, these presenter notes also will be copied into the
Notes Editor of all session attendees.
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When Embedding the File

When you attempt to embed a PowerPoint (.ppt or .pptx), an OpenOffice.org presentation (.ppt,
.sxi and .opd), PDF (.pdf) file or an image file (*.bmp, *.gif, *.jpg, *.jpeg or *.png)1 directly into a
session plan, you will be prompted to convert it to a .wbd file.

If you click on Yes to convert the file, it will be converted to a .wbd file and embedded in the ses-
sion plan.2 If you say No, the file will be embedded in the Embedded Files list in its original file
format. (For details on embedding Whiteboard files, see Step 1: Embed the file. under Adding a
Whiteboard File on page 19.)

Tip: If you want to keep a copy of this file, simply drag it out of the
embedded files list to your desktop or a folder in your file browser.

Through theWhiteboard Editor

You also can load a presentation or image file (not PDF) through the Whiteboard Editor:

1. Load the presentation or image file by doing one of the following:
o Select File > Open.
o Click on the Load Presentation button.

Note: See the chapter entitled The Whiteboard in theModerator’s
Guide for full instructions on loading a file into the Whiteboard.

2. Save your whiteboard file by doing one of the following:
o Select File > Save.
o Press Ctrl+S (⌘S on Mac).

3. Add the file you just created to the session plan. (For details, see Adding a Whiteboard
File on page 19.)

1You also can convert .pict files on a Mac, but only if you have OpenOffice.org installed on your
system.
2The file will retain its original filename – only the file extension will change.

54 Using the Session Plan Editor



Creating a Quiz File
To create a quiz file from within Elluminate Plan!, do the following:

1. Open the Quiz editor by doing one of the following:
o Select View > Quiz.
o Press Ctrl+2 (⌘2 on Mac).
o If the Tab bar is visible, click on the Quiz tab.

2. Load or create quizzes exactly as you would from within Blackboard Collaborate.

Tip: See the chapter entitled The Quiz Manager in the
Moderator’s Guide for instructions on creating a quiz.

3. Save your quiz file by doing one of the following:
o Select File > Save.
o Press Ctrl+S (⌘S on Mac).

Caution: Saving the session plan file when in the Plan editor will
not save the quiz file you just created – you must explicitly save the
quiz file from within the Quiz editor.

You now can add the file you just created to the session plan. (For details, see Adding a Quiz on
page 23.)
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Chapter 2

Page 57

Conducting a Session Using a
Session Plan

Product Overview
After a session plan has been created in Elluminate Plan!, it can be used to conduct your Black-
board Collaborate session. The person who runs the session plan during a Blackboard Col-
laborate session is called the presenter. Only someone with Moderator privileges can be a
presenter and only one Moderator at a time can present the session plan.

Note: Session plans created in Elluminate Plan! 2.0 and 2.1 (.elpx files)
cannot be run in Elluminate Live! 8.5, 9.0 or 9.1 but require Elluminate
Live! 9.5 or higher or Blackboard Collaborate 11. However, you can run
Elluminate Plan! 1.0 session plans (.elp files) in Elluminate Live! 9.5 or
higher and Blackboard Collaborate 11.



To run a session plan, it first must be loaded into the Session Plan Library in Blackboard Col-
laborate and then activated. Activation loads the session plan’s embedded files1 into the session
and displays the session plan to other Moderators (and, optionally, to Participants). You may
have a number of session plans loaded into the Session Plan Library for any one Blackboard Col-
laborate session but only one can be active at any one time.

Note: Session plans cannot be edited within Blackboard Collaborate –
you must do that in Elluminate Plan! For details, see Chapter 1, “Using
the Session Plan Editor”.

The Session Plan Window
When you work with session plans in Blackboard Collaborate, you do so in the Session Plan win-
dow. This window has two distinct views:

l Library View: is used to manage a library of session plan files within a Blackboard Col-
laborate session. This view is called the Session Plan Library.

Note: Only Moderators can access the Session Plan Library.

l Plan Outline View: is used primarily to run a specific session plan. This view is called
the Plan Outline.

Library View – the Session Plan Library
The Session Plan Library has the following components:

1Only those marked for auto-loading.
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Plan Outline View – the Plan Outline
The Plan Outline is displayed differently for Moderators and Participants.

Moderator’s View

Moderators have full access to all the controls needed to work with session plans. For them, the
Plan Outline has the following components:
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Viewing the Embedded Files List

By default, the Embedded Files list is hidden. You can view the list by dragging the divider down,
as depicted below. Similarly, you can hide the list by dragging the divider up:
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Participant’s View

For Participants, the Plan Outline displays the session plan and provides limited functionality. In
order for Participants to see the Plan Outline, a Moderator must select Tools > Session Plan >
Show to All.

The Plan Outline displayed to Participants has the following components:

Opening the Session Plan Window
To open the Session Plan window in Blackboard Collaborate, do one of the following:

o From the Window menu, select Session Plan. If this is the first time you are opening the
Session Plan window in this session, an empty Session Plan Library will be displayed. If
you had previously opened a session plan in this session (but had closed the window), the
Plan Outline will be displayed with the existing session plan.

o From the File menu, select Open > Session Plan and then select a session plan file from
the Open dialog. First, the Session Plan Library will be displayed as the session plan file
loads and then the Plan Outline will be displayed with the selected session plan.
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Changing Views

Viewing a Session Plan

To switch from the Session Plan Library to the Plan Outline, do one of the following:

o Double-click on a session plan in the library.
o Select a session plan in the library and click on the View button.

o Select a session plan in the library and click on the Activate button.

Caution: Use the last option only if you also wish to activate the session
plan. For details on activation, see Activating a Session Plan on page 67.

Viewing the Library

To return to the Session Plan Library from the Plan Outline, click on the Close button in

the Plan Outline toolbar.

Switching to the Minimal Toolbar
From the Plan Outline you can switch to a minimal toolbar, hiding the contents of the Plan Out-
line while maintaining the basic functionality required to run a session plan. This can be useful if
you know your plan well and just need the controls without the view, or if you temporarily want
to see something obstructed by the window.

The minimal toolbar has the following components:

To switch from the Plan Outline to the minimal toolbar, click on the Collapse Window

button in the Plan Outline toolbar.

To switch back (from the minimal toolbar to the Plan Outline), click on the Expand Win-

dow button in the minimal toolbar.
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Closing and Reopening the Session Plan Window
Closing the Session Plan window will not make any session plans already loaded inaccessible – it
just closes the window. To close the window, do one of the following:

l Enter Ctrl+W (Command-W on Mac).

l Enter ALT+F4 (no Mac equivalent).

l Click on the Close Window button in the title bar of the window.

To reopen the window, select Window > Session Plan.

Blackboard Collaborate Menu Items

File Menu
The File menu has standard file-related menu items for session plans:

l Open > Session Plan

l Save > Session Plan

l Print > Session Plan

Tools Menu
The Tools > Session Plan menu provides menu items for four distinct purposes:

l Navigation Commands: Go to Previous Item and Go to Next Item

l Session Plan Properties: Start Timers Automatically, Show Action Icons and Labels.
These controls have equivalent controls within Elluminate Plan! (Duration Timers, Dec-
orations and Labels). See Setting Session Plan Properties on page 74.

l Viewing Options: Show to Moderators Only and Show to All.

l Embedded File Command: Save embedded file to disk or network.

WindowMenu
The Window menu has the Session Plan menu item, which is used to open the Session Plan win-
dow or bring it into focus if it gets hidden behind other windows.
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Working with Session Plans in the Session Plan Library

Loading Session Plans into the Library
To use a session plan in a Blackboard Collaborate session, you must first add it to the Session
Plan Library. You can load session plans into the Session Plan Library at any time during a Black-
board Collaborate session. When you do so, Blackboard Collaborate will upload the session plan
file to the server before adding it to the library.

To manually load a session plan into a Blackboard Collaborate session, open it by doing one of
the following:

o Open a session plan from within the Session Plan Library:

1. Click on the Open button in the Session Plan Library’s toolbar.

2. Select a session plan file from your file browser’s Open dialog.
o Open a session plan using the File menu.

1. From the File menu, select Open > Session Plan.

2. Select a session plan file from your file browser’s Open dialog.

Note: You will first see the Session Plan Library as the session plan file is
loaded. When loading is complete, the session plan will be opened in the
Plan Outline – unless you configure it to behave otherwise by turning off
the Viewing Option preference Open function displays session plan for
viewing. (For details, see Setting Your Preferences on page 74.)

Renaming Session Plans
To rename a session plan within Blackboard Collaborate, do the following:

1. If not already in the Session Plan Library, switch to this view. (For details, see Setting
Your Preferences on page 74.)

2. Select the session plan you would like to rename.

3. Click on the Rename button. The Rename Session Plan dialog will open.

4. Enter the new name for your session plan and click on OK.
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Saving Session Plans
Anyone who can view a session plan can save it to a file. Moderators can save session plan
(.elpx) files in their entirety (native format) or as plain text only. Participants can save session
plans only as plain text.

The native format saves the full session plan, including information regarding its current state of
progress (i.e., which session plan items have been covered). The native file can be reloaded later
into another session and progress can continue where it left off.

Note:When you save a session plan in its native (.elpx) file format, the
contents of the Plan Outline and all embedded files are saved, along with
all properties and preferences.

The plain text version contains only the text that is displayed by the session plan for Topics,
Actions and Text Items, indented appropriately to reflect the Plan Outline.

Tip: A plain text outline can be useful as a basis for taking class notes.

To save a session plan file, do the following:

1. Open the Save Session Plan dialog by doing one of the following:
o Select File > Save > Session Plan.
o Press Ctrl+S (⌘S on Macintosh).

Note: If you have the main Blackboard Collaborate window
in focus (rather than the Session Plan window), when you
press the keyboard shortcut, you will be presented with a
dialog from which you need to select Session Plan from a list
of printable files (others are Chat Conversation and White-
board).

o Click on the Save button in the Plan Outline toolbar.

2. Select the file type in which to save your session plan – .elpx for native format or .txt for a
plain text file.

3. Enter a name for your saved file and click on Save.

Printing Session Plans
Anyone who can view a session plan can print it. For Participants, the printout will include only
the text that is displayed by the session plan for Topics, Actions and Text Items, indented appro-
priately to reflect the Plan Outline. For Moderators, completion indicators, the progress marker
and suggested durations will be printed as well.
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To print a session plan, do one of the following:

o Select File > Print.
o Press Ctrl+P (⌘P on Macintosh).
o Click on the Print button in the Plan Outline toolbar.

Tip: If required, first specify your page setup options in the Page Setup
dialog (File > Page Setup).

Closing Session Plans
To close a session plan while in the Plan Outline, click on the Close button in the Plan Out-

line. You will be returned to the Session Plan Library.

Note: Closing does not deactivate an active plan. Deactivation is a sep-
arate operation.

Removing Session Plans from the Library
Session plans can be removed from the Session Plan Library. When removed, they are no longer
available for use in the Blackboard Collaborate session.

To remove a session plan from the library, select the plan and click on the Remove button

in the Session Plan Library toolbar. If the session plan you are removing is currently active, it
will be deactivated.

Note: If someone else is currently viewing this session plan, their Session
Plan window will either close (Participant) or will return to the library
view (Moderator).

Saving Embedded Files
Files in the Embedded Files list can be saved externally to your desktop or network.

1. Show the Embedded Files list by dragging down the divider.

2. Selecting one or more the files to be saved.

3. Click on the Save Embedded File button in the Tool bar.

4. In the Save dialog, select the folder in which you would like the file(s) saved.
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Activating a Session Plan
Before you can run a session plan, it must first be activated. By default, this happens auto-
matically when you load the session plan into the Blackboard Collaborate session. (You can over-
ride this behavior by de-selecting the preference View function activates plan in session. For
details, see Viewing Options on page 76.)

When you activate a session plan, three things will happen:

l All embedded files that have been marked for automatic loading (see Adding Content Files
on page 18) will be loaded into the session.

l The session plan will be displayed to other Moderators (and, optionally, to Participants).

l Session plan items will become accessible (e.g., you will be able to click on them or navi-
gate to them via toolbar buttons or menu items).

Caution: Before activating a session plan, be sure that you are in the
Main Room of the whiteboard. If you are in your private Work Area, the
embedded whiteboard files that have been marked for automatic loading
will not be loaded.

To manually activate a session plan from within a Blackboard Collaborate session, do one of the
following:

o If you are in the Session Plan Library view, select the session plan you would like to acti-
vate and click on the Activate button.

o If you are in the Plan Outline view, click on the Activate button. The current session

plan will be activated.

Displaying a Session Plan to Participants
By default, only Moderators will be able to view a session plan once it is activated. To display the
session plan to Participants as well, select Tools > Session Plan > Show to All.

When Participants are given permission to view the session plan, they only will be able to see
and scroll through the items in the Plan Outline and print or save the Plan Outline in plain text
format. Participants can neither run session plans (i.e., execute items in the Plan Outline) nor
access the Session Plan Library.
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Running a Session Plan
The process of running a session plan typically involves the presenter navigating through the
Plan Outline from top to bottom using the mouse, keyboard shortcuts, arrow buttons or Black-
board Collaborate menu commands. Alternatively, you can move backwards through the Plan
Outline or move directly to a specific item (mouse click only).

Note: You can easily identify Actions in the Plan Outline by hovering over
them with the mouse – they will be highlighted with an underline. Topics
and Text Items will not be underlined as they do not trigger any events in
Blackboard Collaborate.

When you move to an Action in the Plan Outline, a corresponding event is triggered in Black-
board Collaborate. If you move back to a previously triggered Action, it will be executed again.
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Note: You can configure the session plan so it won’t execute previously
triggered Actions by turning off the Viewing Option preference Execute
items when progressing backwards. (For details, see Setting Your Pref-
erences on page 74.)

When you move to a Compound Action, all of the sub-Actions contained within it are executed
in the order in which they were listed when the Compound Action was created in Elluminate
Plan!

Note: If an Action fails you will get an error message. You can suppress
error messages by turning on the Viewing Option preference Suppress
error dialogs when executing actions. (For details, see Setting Your Pref-
erences on page 74.)

As you move through the session plan, the progress marker points to the item that is current
and completion indicators show which items have been covered. These indicators are displayed
to all users who can view the session plan, but only the presenter can manipulate them.

Moving Through Session Plan Items
There are several options for moving to (and executing) items in the Plan Outline.

To navigate to the next item, do one of the following:

o Click on the Next button.

o Enter Crtl+Close Bracket (⌘] on Macintosh).
o Select Tools > Session Plan > Go to Next Item.
o Click on the next item with your mouse.

To navigate to the previous item, do one of the following:

o Click on the Previous button.

o Enter Crtl+Open Bracket (⌘[ on Macintosh).
o Select Tools > Session Plan > Go to Previous Item.
o Click on the previous item with your mouse.

To navigate to an item that is neither next or previous to the current item, do the following:

o Click on the desired item with your mouse.
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Tracking Your Progress
With one exception (noted below), when you move to an item in the Plan Outline it is marked as
the current item by the progress marker: .

Actions and Text Items that have been visited are visually marked as covered in the session plan
by a change in text color and by completion indicators (the bullets at the left), both of which can
be configured under Viewing Options preferences. (For configuration details, see Setting Your
Preferences on page 74.)

Note: Topics and Compound Actions are marked as covered only when all of the
sub-items contained within them have been viewed or executed.

Tip: You can toggle a completion indicator off and on by clicking on it
with your mouse. The text color also will toggle. To clear all the
completion indicators at once, Ctrl+Click (⌘Click on Mac) on any
completion indicator. Conversely, to toggle all completion markers on,
Ctrl+Click (⌘Click on Mac) on any blank area in the completion indicator
column.

When you move to the last item in the Plan Outline, you will be notified that you have reached
the end of the session plan. When you click Next, you will be returned to the beginning of the
Plan Outline.

Progress within a session plan is persistent across sessions if you save the session plan before
leaving the session. The completion indicators and progress marker will mark where you left off
in the presentation (the current item) so you can resume where you left off in a subsequent ses-
sion.
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Tip: If you want to start your next session at a different place in the Plan
Outline, before you save and exit the session plan, either move the
progress marker to the desired spot or toggle off the desired completion
markers.

Duration Timers
If the session plan creator specified a suggested duration for a Topic, Text Item or Action, it will
be displayed to the right of the item in the Plan Outline. If the timer was configured to start auto-
matically, it will do so when you move to the Topic or Action; otherwise, you need to start it
manually.

To start or stop a duration timer manually, click on it. The bubble around the sug-
gested time will turn red, indicating that the timer is active.

The timer counts down from the suggested time value to zero and stops when it reaches zero. It
will also stop when you click on it again or when you move to another item, unless that other
item is a sub-item.

When a timer is stopped or reaches zero, the red bubble will disappear and it will return to its
original state – you can take this as a cue that it is time to move on.

Note: Only one duration timer can run at a time. If you move to a sub-
item that also has a timer, the sub-item’s timer will start running only if
its parent's timer (or an earlier sub-item’s timer) has stopped.
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Presenter Notes
When a Topic or Action has presenter notes, they
are displayed at the bottom of the Session Plan win-
dow when you move to the Topic or Action.

The size of the presenter notes area can be
increased or reduced by moving the divider with
the mouse. By default, it shows two lines of text.
The size is retained from note to note as well as
between Blackboard Collaborate sessions. If the
text does not fit in the available space, a vertical
scroll bar will appear. You also can adjust the size
of the text by setting the Note Font in the Pref-
erences panel. For details, see Display Settings on
page 75.

Note: Presenter notes are displayed to Moderators only.

Control of the Session Plan
Only one Moderator at a time can control a session plan (i.e., be the presenter). The Moderator
who first activates the session plan automatically will be the initial presenter.

If the session plan is manually loaded into the Blackboard Collaborate session and auto-activated
(the option View function activates plan in session is selected under Preferences), the person
who loads the session plan also activates it and, thereby, will be the presenter. If the session plan
is pre-loaded and auto-activated (the option View function activates plan in session is selected
under Preferences), the first Moderator to join the session is the one who loads and activates the
session plan and, thereby, will be the presenter. (See Viewing Options on page 76 for infor-
mation on View function activates plan in session.)

Requesting/Relinquishing Control of the Session Plan
Control of the presenter privilege can be relinquished independently by the current presenter or
granted to another Moderator who requests control. If you are the current presenter, to relin-
quish control of the session plan, click on the Request Control button. Now any Mod-

erator can click on the Request Control button and be granted control automatically (without
requesting permission from another Moderator).
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If you are not the presenter but would like control, click on the Request Control button.

The existing presenter has the option of granting or denying you control via the Control Request
dialog:

Note: If the current presenter does not respond within 10 seconds, the
request will be granted automatically.

When the current presenter grants your request, the Request Control button will become

selected and the Next and Previous buttons will become enabled, indicating that you now have
control.

If the existing presenter does not give up control, you will receive a message to that effect:

Controlling the Session Plan from a Breakout Room
If you are the current presenter of the session plan and you move to a breakout room, you are
still in control of the session plan – exactly as if you were still in the main room.

Only one session plan can be open in any given session, so there are never separate session plans
running in breakout rooms.

When the Presenter Leaves the Session
If the presenter leaves the session without first relinquishing control of the session plan, he or
she will remain the presenter (in absentia) until another Moderator takes control by clicking on
the Request Control button. If no Moderator takes control, there will be no presenter.

If no one takes control and the old presenter returns to the session, he or she will resume con-
trol.
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Setting Session Plan Properties
The session plan properties within Blackboard Collaborate are identical to those in Elluminate
Plan!: Start Timers Automatically, Show Action Icons and Labels. By default, the values of these
properties will be those saved in Elluminate Plan! when the session plan was created or edited.
However, you can override the existing properties by selecting them under Tools > Session Plan.

Note: For details on session plan properties, see Setting Session Plan
Properties on page 74.

Setting Your Preferences
Session Plan preferences in Blackboard Collaborate are application settings that affect the look
and behavior of session plans within Blackboard Collaborate – they are not associated with a spe-
cific session plan. Preferences are your personal settings1 for how you want session plans to look
and behave within Blackboard Collaborate.

To open the Preferences dialog, select Tools > Preferences >Session Plan.

Tip: For a quick overview of the Session Plan Preferences dialog, see
Setting Elluminate Plan! Preferences on page 49. For a more in-depth
discussion of using the Preferences dialog, see the chapter entitled Getting
Stared in theModerator’s Guide.

1When someone else uses your session plan in Blackboard Collaborate, they will see the session plan
with the fonts, etc. they have set up under their own Preferences.
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Display Settings
Used to specify the appearance of item names in the Plan Outline. The default values for font
name and size are based on the system settings for your specific platform.

One thing consistent across all platforms is that the Topic Font is bold and the Text Item font is
italics.

Set your font name, font style and font size preferences for the following by making selections
from the drop-down menus:

l Topic Font: Used to set the appearance of Topic items.

l Action Font: Used to set the appearance of Action items.

l Text Item Font: Used to set the appearance of Text Items.

l Note Font: Used to set the appearance of Presenter Notes.
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Viewing Options
Used to control behavior of session plans within Blackboard Collaborate.

n Open function displays session plan for viewing: specifies whether or not to open a ses-
sion plan in the Plan Outline after it is loaded into the Session Plan Library. (The default is
on.)

n View function activates plan in session: specifies whether or not to activate a session plan
automatically when it is loaded into the Session Plan Library. (The default is on.)

n Execute items when progressing backwards: specifies whether or not to execute items
that you have moved to using the Go to Previous Item menu item (or its associated key-
board shortcut) or the Previous button. (The default is on.)

n Execute items when dragging progress marker: specifies whether or not to execute items
that have been moved to via dragging the progress marker with your mouse. (The default
is off.)

n Clicking on item moves progress marker: specifies whether or not to move the progress
marker to an item that has been clicked on with your mouse. (The default is on.)

n Suppress error dialogs when executing actions: specifies whether or not to display error
messages when actions cannot be executed. (The default is off.)
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n Color of covered items: specifies the color to be used for the completion indicator and
text of items that have been covered.

The default color is purple. To change the default, click on the purple square to open a
color selector dialog and select another color.

n Color of action hyperlinks: specifies the color to be used to indicate executable items
(Actions) when hovered over by mouse.

The default color is blue. To change the default, click on the blue square to open a color
selector dialog and select another color.

Session Plans and Recordings
The recorder is considered a normal Participant in a session so, if the privilege to view the active
session plan was set to Show to All, the Session Plan window will come up in the recording as it
did for attendees of the live session. If this is the case, while viewing the recording you can hide
the Session Plan window by using its Close Window button, and show it again using Window
> Session Plan, just like you can during a live session. You also can Save and Print the session
plan as you would during a live session.

Note:While a session is being recorded, when the presenter moves to a
session plan Topic, an index entry called “Topic Changed” is automatically
inserted into the recording.
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Getting Help
Help with Elluminate Plan! is available via the following resources:

n Elluminate Plan! Product Download Page:

http://www.elluminate.com/Other/Download/Plan!_V2/?id=150

l Also accessible within Elluminate Plan! by selecting Help > Elluminate Plan! Help

l Contains software downloads and links to documentation, sample session plans and
training materials.

Tip: Be sure to download the Elluminate Plan! User’s Guide from
the webpage. The document will not be accessible if you are not
connected to the Internet – which may be the case when you are
creating session plans.

n Elluminate Plan! Product Information Page:

http://www.elluminate.com/Products/Elluminate_Learning_Suite/Elluminate_
Plan!/?id=78

l Also accessible within Elluminate Plan! by selecting Help > Elluminate Plan! Home

l Contains product overview information, including system requirements.

http://www.elluminate.com/Other/Download/Plan!_V2?id=150
http://www.elluminate.com/Other/Download/Plan!_V2?id=150
http://www.elluminate.com/Products/Elluminate_Learning_Suite/Elluminate_Plan!?id=78
http://www.elluminate.com/Products/Elluminate_Learning_Suite/Elluminate_Plan!?id=78
http://www.elluminate.com/Products/Elluminate_Learning_Suite/Elluminate_Plan!?id=78
http://www.elluminate.com/Products/Elluminate_Learning_Suite/Elluminate_Plan!?id=78


n Elluminate Plan! Sample Plans Page:

http://www.elluminate.com/Services/Training/Plan!_Plans/?id=280

l Contains sample session plans that you can download for your own use.

Documentation and training materials for Blackboard Collaborate Web Conferencing are avail-
able on the On-Demand Learning Center:

http://www.blackboard.com/Platforms/Collaborate/Services/On-Demand-Learning-
Center/Web-Conferencing.aspx
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Rules for Inserting and Indenting
Session Plan Items

When you create a session plan, you can construct relationships between various items to form a
hierarchy within the session plan. Items that “contain” other items are called parent items.
Items contained by (indented under) a parent item are called child items. Here is an illus-
tration:

Topic 1 is the parent of Topic 2.

Topic 2 is a child (sub-Topic) of Topic 1 and a parent of Topic 3,
Text item 1 and Action 1.

Compound Action 1 is the parent of sub-Actions 1 and 2.

Topic 4 and Text item 2 are neither parents nor children of
other items.

Only certain types of items can form the parent/child relationship.



Item Parent/Child Rules

Topic A Topic can be the parent of any type of item: another Topic
(sub-Topic), Text item, Action or Compound Action.

Compound Action A Compound Action can be the parent of Actions only.

Action An Action cannot be a parent to any other items.

Text item A Text item cannot be a parent to any other items.

Inserting New Items
Insertion Rule for New Items: A new item will be inserted immediately below the current
selection (see Examples 1, 3 and 4 below), unless doing so breaks one of the parent/child rules
(see Examples 2 and 5 below).

Indentation Rule for New Items: A new item will be indented at the same level as the cur-
rent selection (see Examples 1 and 2 below), unless the currently selected item already has chil-
dren (see Example 3 below) or the currently selected item is a Compound Action and the new
item is an Action (see Example 4 below).

Note: If you want your new item to be a parent, you will have toman-
uallymove it to the left or the sub-items to the right to create the rela-
tionship. If the relationship you are trying to form does not conform to
the Parent/Child rules, you will not be able to move the item(s).
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Example 1 – Sample
Plan

Add any type of new
item

Description

When adding a new Topic, Action,
Compound Action or Text item, it will
adopt the indentation of the previously
selected item (Text item 1).

Example 2 – Sample
Plan

Add Topic or Text
item

Description

When a Compound Action is selected,
a new Topic or Text item will be added
after the last child item of the Com-
pound Action and will be indented at
the same level as the Compound
Action.

Example 3 – Sample
Plan

Add any type of new
item

Description

When adding a new Topic, Action,
Compound Action or Text item, it will
adopt the indentation of the previously
selected item’s children to prevent it
from becoming their parent.

Example 4 – Sample
Plan

Add an Action Description

When a Compound Action is selected,
a new Action will automatically
become its child.

Example 5 – Sample
Plan

Add a Topic or Text
item

Description

When a child of a Compound Action is
selected, a new Topic or Text item will
be added after the last child item of the
Compound Action and will be indented
at the same level as the Compound
Action.
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Moving Items
The Parent/Child Rules govern how items can be moved in the session plan. Below are the rules
that determine where and at what level of indentation items will be placed when moved
up/down or left/right in the session plan.

Insertion Rule for Moving Items Up and Down: An item will be moved to the next pos-
sible location. Usually, this is immediately above or below the adjacent item (see Examples 1 and
4 below). If moving the item above or below an adjacent item would break a Parent/Child rule,
the item will be moved to the next possible location (see Example 2 below).

Indentation Rule for Moving Items Up and Down:When an item is moved it will be
indented at the same level as the adjacent item (the one above if moving up and the one below if
moving down). (See Example 1 below.)

l If the adjacent item below (if moving down) already has children, the moved item will be
indented at the same level as the children (see Examples 3 and 4 below).

l If the adjacent item is a Compound Action and the moved item is an Action, it will be
indented at the same level as the children – it will become a child of the Compound
Action. (See Example 4 below.)

l If the item being moved is a Topic or Compound Action, its existing children will be
moved with it to maintain the parent/child relationship. (See Example 3 below.)
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Example 1 – Initial
Order

Topic 2 Moved
Down

Description

Topic 2 moves down one row and
takes the same indentation as the
item below it (Topic 3).

Example 2 – Initial
Order

Topic 2 Moved Up Description

Topic 2 moves up three rows since a
Topic cannot be a child of a Com-
pound Action. It takes the same
indentation as the item above it
(Compound Action).

Example 3 – Initial
Order

Topic 1 Moved
Down

Description

Topic 1 moves down one row and is
indented at the same level as the
child of the item below it (Topic 2).
The child of Topic 1 (Text item)
moves with it to maintain their par-
ent/child relationship.

Example 4 – Initial
Order

Action Moved Down Description

The Go to Screen Action moves
down one row and becomes a child
of the Compound Action.
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Indentation Rule for Moving Items Left and Right:When an item is moved left or right
it will always stay on the same row.

l If the item being moved is a Topic or Compound Action with children, the children will be
moved with it to maintain the relationship. (See Example 5 below.)

l If moving the item left or right goes against one of the Parent/Child rules, moving is not
possible and the item will remain where it is. (See Example 6 below.)

Example 5 – Initial Order Topic 2 Moved Left Description

As Topic 2 moves one level of inden-
tation to the left, its children move
with it to maintain the parent/child
relationship. Topic 3 now also
becomes a child of Topic 2.

Example 6 – Initial
Order

Action Moved Left Description

If attempting to move the Go to
Screen Action left, it will not move.
Doing so would make it a parent of
the Actions below it – which is not
a valid parent/child relationship.
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Supported Commands
A session plan interacts with the various Blackboard Collaborate modules through a set of
Actions that trigger events in Blackboard Collaborate. These modules and Actions are listed
below:



Elluminate Plan! Action Description

Differences between Elluminate
Plan! Action and Blackboard Col-
laborate command (For details see
Enhanced Actions on page 37.)

Application Sharing

Share Application Share an application, given a ref-
erence to an application,
whether to include the menu bar
and whether to engage pre-
sentation mode. Optional: a ref-
erence to a file to be opened by
the application can be given.

In Elluminate Plan!, the Share
Application Action can launch
the application whereas in Black-
board Collaborate the application
must already be running in order
for you to share it.

Share Desktop Share the entire desktop given
whether to engage presentation
mode.

N/A

Share Screen Region Share a screen region, given its
coordinates and whether to
engage presentation mode.

As of Blackboard Collaborate ver-
sion 11, this command is no
longer supported.

Pause Sharing Pause sharing application. N/A

Resume Sharing Resume sharing application. N/A

Stop Sharing Stop sharing application. N/A

Audio

Set Maximum Talkers Set up the maximum number of
simultaneous talkers allowed in
the session.

N/A

Transmit Audio Turn on the microphone of the
presenter (Moderator controlling
the session plan).

N/A

Stop Audio Turn off the microphone of the
presenter (Moderator controlling
the session plan).

N/A

Breakout Room

Create Room Create a breakout room given a
room name.

N/A
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Elluminate Plan! Action Description

Differences between Elluminate
Plan! Action and Blackboard Col-
laborate command (For details see
Enhanced Actions on page 37.)

Distribute Participants Distribute the participants, given
the number rooms to create, the
base room name and whether to
include moderators.

N/A

Split Participants Split the participants, given the
size of groups to create, the base
room name and whether to
include moderators.

N/A

Return All to Main
Room

Return all participants to main
room.

N/A

Return All to Previous
Room

Return all participants to their
previous room, given whether to
include Moderators.

N/A

Close Room Close a room, given a room
name.

N/A

Close All Rooms Close all breakout rooms and
returns all participants to the
main room.

N/A

Chat

Send Chat Message Send a Chat message to the spec-
ified participants or rooms. Can
be sent as an Announcement.

In Blackboard Collaborate, you
can send a chat message to
selected participants. This is not
a viable option in a session plan
because you can’t know in
advance who will be attending
the session. Therefore, the only
options in the Recipients menu
of the Send Chat Message Action
are All Rooms, This Room and
Moderators.
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Elluminate Plan! Action Description

Differences between Elluminate
Plan! Action and Blackboard Col-
laborate command (For details see
Enhanced Actions on page 37.)

File Transfer

Load File for Transfer Load a file to be transferred,
given a URL or the name of a file
embedded in the session plan
and whether to prompt par-
ticipants.

N/A

Prompt to Save File Prompt participants to save a file
that has been loaded for transfer.

N/A

Multimedia

Load Multimedia Load a multimedia file, given a
URL or the name of a file embed-
ded in the session plan.

N/A

Play Multimedia Play a multimedia file, given its
name in the multimedia library.

N/A

Stop Multimedia Stop playing the current mul-
timedia file.

N/A

Polling

Set Poll Type Set the poll type, which is either
none, yes or no, A to C, A to D,
A to E, or pace.

N/A

Hide Poll Responses Hide the poll responses. N/A

Show Poll Responses Show the poll responses. N/A

Lock Poll Responses Lock the poll responses. N/A

Unlock Poll Responses Unlock the poll responses. N/A

Publish Poll Statistics to
Whiteboard

Publish the poll statistics to the
whiteboard.

N/A

Presentation

Present Engage presentation mode, given
the content to present and
whether to engage presentation
mode locally.

As of Blackboard Collaborate ver-
sion 11, this command is no
longer supported.
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Elluminate Plan! Action Description

Differences between Elluminate
Plan! Action and Blackboard Col-
laborate command (For details see
Enhanced Actions on page 37.)

Stop Presenting Stop presenting. As of Blackboard Collaborate ver-
sion 11, this command is no
longer supported.

Profile

Set Viewable Profiles Specify who can view profiles of
participants: None (no one),
Moderators or All (everyone).

N/A

Quiz

Load Quiz Load a quiz, given a URL or the
name of a file embedded in the
session plan.

N/A

Start Quiz Start a quiz, given its name in
the quiz library and the time
limit.

N/A

Stop Quiz Stop the current quiz. N/A

Recorder

Start Recording Start recording. N/A

Pause Recording Pause recording. N/A

Add Recording Index Add an index entry into the
recording, given a description.

N/A

Telephony

Configure Tel-
econference

Set up the connection infor-
mation for the teleconference.

N/A

Connect Teleconference Connect the session to the tel-
econference, providing a bridge
between the teleconference user
and VoIP users.

N/A

Disconnect Tel-
econference

Disconnect the session from the
teleconference.

N/A
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Elluminate Plan! Action Description

Differences between Elluminate
Plan! Action and Blackboard Col-
laborate command (For details see
Enhanced Actions on page 37.)

Timer

Start Timer Start a timer, given a starting
time, whether it is visible to all
participants, and the type of noti-
fication: None, a Message, a
Sound or Both.

N/A

Pause Timer Pause the timer. N/A

Resume Timer Resume the timer. N/A

Stop Timer Stop the timer. N/A

Video

Set Maximum Cameras Set up the maximum number of
simultaneous cameras allowed in
the session.

N/A

Preview Video Turn on the video camera of the
presenter (Moderator controlling
the session plan) and displays it
to the presenter only.

N/A

Transmit Video Turn on the camera of the pre-
senter (Moderator controlling
the session plan) and displays
video to everyone in the session.

N/A

Stop Video Turn off the camera of the pre-
senter (Moderator controlling
the session plan) when the pre-
senter is either previewing or
transmitting video.

N/A

Web Tour

Go to Web Tour URL Start a web tour or change the
URL of a tour already in prog-
ress.

N/A

Stop Web Tour Stop the web tour. N/A

Publish Web Tour URL
to Chat

Publish the web tour URL to
Chat.

N/A
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Elluminate Plan! Action Description

Differences between Elluminate
Plan! Action and Blackboard Col-
laborate command (For details see
Enhanced Actions on page 37.)

Publish URL Push a URL to participants,
given a URL.

N/A

Whiteboard

Load File into White-
board

Load a whiteboard, given a URL
or the name of a file embedded
in the session plan as well as an
operation (Replace All Screens,
Insert After Screen or Insert At
End).

In Blackboard Collaborate,
Insert At End is called After cur-
rent screen, however, the func-
tionality is the same.

Go to Next Whiteboard
Screen

Go to the next screen, given
whether to remain within the
current Topic.

N/A

Go to Previous White-
board Screen

Go to the previous screen, given
whether to remain within the
current Topic.

N/A
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Elluminate Plan! Action Description

Differences between Elluminate
Plan! Action and Blackboard Col-
laborate command (For details see
Enhanced Actions on page 37.)

Change Whiteboard
Screen

Change screen, given the target
screen, whether to search the
screen starting at the screen
group, and whether to search
sub-Topics.

In Blackboard Collaborate, you
can see the screens to which you
want to navigate. When navi-
gating to screens via a session
plan, you need to define the loca-
tion for the new screens using
the Target Screen field and asso-
ciated options.

Copy Screens to Main
Room

Copies all the screens in the
selected breakout rooms and
pastes them into the main room.
If no breakout rooms are spec-
ified, screens from all breakout
rooms are copied.

N/A

Copy Screen to Break-
out Rooms

Copies the specified screen in the
main room and pastes it into the
specified breakout room(s). If no
breakout room is specified, will
copy the screen into all breakout
rooms.

N/A

Protect Whiteboard Disables the ability of par-
ticipants to save or print the
whiteboard.

N/A

Unprotect Whiteboard Enables participants to save or
print the whiteboard.

N/A
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Copyright
This document contains confidential proprietary information and is protected by law. This doc-
ument and the information contained in it are intended for authorized users only and may be
used only for the express purpose of legally accessing and using Blackboard Inc. products; any
other use, without Blackboard Inc.’s prior written permission, is strictly prohibited.

© 2011 Blackboard Inc. All Rights Reserved.
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Trademarks
Blackboard Collaborate® and Blackboard Collaborate Web Conferencing® are registered trade-
marks of Blackboard Inc. and its subsidiary companies. All rights reserved.

Elluminate Plan!TM is a trademark of Blackboard Inc. and its subsidiary companies. All rights
reserved.

Elluminate Publish!TM, Elluminate Unplugged!TM, and Elluminate Unplugged! RecordingTM are
trademarks of Blackboard Inc. and its subsidiary companies. All rights reserved.

All other brand or product names are trademarks or registered trademarks of their respective
companies or organizations.
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